Project

General

Profile

Bug #10

mdrun - exploding system with FEP turned on

Added by David Bostick about 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Files to reproduce this bug can be downloaded from

http://www.scripps.edu/~dbostick/temp/fep_bug.tgz

the naming of the files are explanatory. See the README file for explicit
instructions. I was able to reproduce the bug on Mac OS X (G5 machine), and on a
linux cluster (x86-64).

I found a problem when trying to do a FEP run transforming a

blocked GLUH

--> GLU in water. Here is what I observed:

1) When free_energy = no: a test run goes to completion

2) When doing the equivalent run with free_energy = yes as follows:

;Free Energy Perturbation

free_energy = yes

init_lambda = 0.0

delta_lambda = 0.0

the exact same run crashes on the first step. step-1.pdb shows the

initial configuration and step0.pdb shows an apparently exploded

fep_bug.tgz (581 KB) fep_bug.tgz files to reproduce (1) crashed fep run and (2) successful non-fep run David Bostick, 09/10/2005 08:35 PM

History

#1 Updated by David Bostick about 14 years ago

Created an attachment (id=2)
files to reproduce (1) crashed fep run and (2) successful non-fep run

see README file

#2 Updated by Erik Lindahl about 14 years ago

This error seems to be caused by a bug in the free energy version of switch VdW
interactions.

#3 Updated by Erik Lindahl about 14 years ago

We always use the combined Coulomb+VdW table for all free energy interactions (including 1,4) now.

Also available in: Atom PDF