Project

General

Profile

Bug #1008

mdrun fails when run with FE code and 4.5-generated tpr

Added by Sander Pronk over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

mdrun fails with a segmentation fault when presented with a tpr file made with grompp from gromacs 4.5, with free energy=on and foreign-lambdas. The first of several crashes occurs in

#0 0x00007ffff704bc1c in pr_fepvals (fp=0x6459f0, indent=3, fep=0x65fb00,
bMDPformat=0) at /nethome/sander/git/gromacs-4.6/src/gmxlib/txtdump.c:569
#1 0x00007ffff704d2f8 in pr_inputrec (fp=0x6459f0, indent=3,
title=0x42fda6 "Input Parameters", ir=0x645ce0, bMDPformat=0)
at /nethome/sander/git/gromacs-4.6/src/gmxlib/txtdump.c:733
#2 0x000000000040d6b3 in mdrunner (nthreads_requested=1, fplog=0x6459f0,
cr=0x644fc0, nfile=36, fnm=0x7fffffffbcb0, oenv=0x645630, bVerbose=1,
bCompact=1, nstglobalcomm=-1, ddxyz=0x7fffffffc820, dd_node_order=1,
rdd=0, rconstr=0, dddlb_opt=0x433703 "auto", dlb_scale=0.800000012,
ddcsx=0x0, ddcsy=0x0, ddcsz=0x0, nstepout=100, resetstep=-1, nmultisim=0,
repl_ex_nst=0, repl_ex_nex=0, repl_ex_seed=-1, pforce=-1, cpt_period=15,
max_hours=-1, deviceOptions=0x43370f "", Flags=7168)
at /nethome/sander/git/gromacs-4.6/src/kernel/runner.c:445
#3 0x0000000000424478 in main (argc=1, argv=0x7fffffffda48)
at /nethome/sander/git/gromacs-4.6/src/kernel/mdrun.c:685

topol.tpr (72.2 KB) topol.tpr Sander Pronk, 09/23/2012 02:27 PM
fe_crash.tar.gz (43.3 KB) fe_crash.tar.gz conf, .top & .mdp Sander Pronk, 09/23/2012 02:27 PM

History

#1 Updated by Szilárd Páll over 6 years ago

Is 55f25f80 the fix for this bug?

#2 Updated by Teemu Murtola over 6 years ago

  • Status changed from New to Feedback wanted

Repeating Szilard's question.

#3 Updated by Sander Pronk over 6 years ago

I have another fix for this (together with fixes for #1090) - so it's not quite dead yet.

#4 Updated by Michael Shirts over 6 years ago

It seems to be running fine now with this tpr. I KNOW I worked on this and it ended up fixed (I have a directory with the same files checked out on that date, and a lot of debugging information in it), but I can't seem to identify which code check-in fixed it.

#5 Updated by Erik Lindahl over 6 years ago

  • Status changed from Feedback wanted to Closed

Oh well, at least it is no longer a bug that needs fixing, so I'm closing it for now.

Also available in: Atom PDF