Project

General

Profile

Bug #101

problems with CVS g_hbond

Added by Jonathan Moore about 13 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I'm still having problems with g_hbond.

- The hbond existence matrix in the -hbm output does not match the list of
hbonds in the ndx file from -hbn (see described a comparison of the output from
two runs described below)

- Also, it outputs "No option -g" when no -g command line option has been tried

- Also, sometimes the "Pairs within 0.35 nm" is smaller than "Hydrogen bonds" in
the -num output. This makes no sense to me if I understand correctly that
"within 0.35 nm" is one of the criteria being used to determine if an hbond
exists. (see the -num output from test1...the O5/3pos case)

- Also, for the groups O5 and 3pos metioned below, the -hbn .ndx lists the
acceptors from both O5 and 3pos groups in [ acceptors_O5 ] and [ acceptors_3ps ]
(see the -num output from test1...the O5/3pos case)

I'm using a CVS version, g_hbond.c includes "$Id: gmx_hbond.c,v 1.27 2006/06/15
12:33:03 spoel Exp $" and g_hond -h replies "VERSION
3.3.99_development_20060330" (that sounds to me like it was after the changes
made by Erik Marklund...whose email to the developers list is what prompted to
go get the CVS code)

I ran g_hbond twice for the same xtc file. The first time I choose groups "O5"
and "3pos". The second time I choose both groups to be "polymer." O5 and 3pos
are both subsets of polymer.

2 hbonds are identified between O5 and 3pos. 16 hbonds are identified between
polymer and polymer, including the same 2 identified between O5 and 3pos (as can
be seen by finding the same patterns in the existence matrix of the -hbm
output). However, the .ndx files from the -hbn output identify the hbonds as
being for different sets of donors and acceptors. That is, the triplets 47 48
42 and 19 20 14 are identified from O5/3pos analysis. Those same existence
matrix patterns appear in the analysis of polymer/polymer but are identified as
2 1 11 and 64 65 58. 47 48 42 and 19 20 14 are triplets that should be included
in a 05/3pos analysis but 2 1 11 and 64 65 58 are not.

g_hbond.zip (764 KB) g_hbond.zip test case Jonathan Moore, 08/22/2006 10:56 PM

History

#1 Updated by Jonathan Moore about 13 years ago

Created an attachment (id=65)
test case

Files necessary to reproduce bug. The xtc files has had the solvent removed to
reduce the file size.

#2 Updated by David van der Spoel about 13 years ago

Seems like you don't have the proper version yet. Please try

rm gxm_hbond.c
gmxcvs update -j release-3-3-patches gmx_hbond.c

the version should then look like this:

  • $Id: gmx_hbond.c,v 1.16.2.16 2006/07/03 14:25:08 erikm Exp $

please report back if there are more problems.

#3 Updated by Erik Marklund about 13 years ago

I've checked the attached files and could see that most of the stuff weren't
bugs at all. A few things (like the fuss about the -g option) seem to be proper
bugs, however, and I'll have a closer look whenever I have some time to spare
(never!) if noone else beats me to it.

Not bugs:
- pairs within 0.35...
- hbm-hbn consistency (not bug, but confusing. Maybe a remark could help to clarify)

Possible bugs:
- g option
acceptors appear in both groups.

#4 Updated by Jonathan Moore about 13 years ago

If the reverse ordering in -hbm and -hbn output isn't a bug, then the
documentation certainly needs to be updated. The online and paper manuals say
that the -hbm output "Ordering is identical to that in -hbn index file" which
obviously is not the case if it is reversed.

It would also be nice to include a better description of "Pairs within 0.35
nm" in the documentation.

#5 Updated by Jonathan Moore about 13 years ago

I got ahold of this version of gmx_hbond.c
  • $Id: gmx_hbond.c,v 1.16.2.16 2006/07/03 14:25:08 erikm Exp $

I had some difficulty with CVS...I can't access it from work. I could from
home, but the commands David suggested (like rm) weren't working (some error
related to read/write permissions or something), or at least I wasn't
knowledgeable enough to make them work. Playing around (I'm not familiar with
CVS) I eventually was able to get the patch merged in with the old version and
then had to remove the old stuff by hand.

Anyway...I was unable to compile gmx_hbond.c,v 1.16.2.16 because the compiler
complained that correl was undeclared here:

#ifndef WITHOUT_FFTW
correl = init_correl(n2);
#endif

I stuck in a #define WITHOUT_FFTW like I saw in 3.3RC3 and moved on...I assume
no disasters will result

#6 Updated by David van der Spoel about 13 years ago

Added the -g option back in for dumping of the hbmap to hbond.log.

#7 Updated by David van der Spoel about 13 years ago

Jonathan,

are there any further problems with the current CVS code?

#8 Updated by Jonathan Moore about 13 years ago

(In reply to comment #7)

Jonathan,
are there any further problems with the current CVS code?

I'm not aware of any additional bugs other than the ones I mentioned (I
haven't checked on them since then...accesssing CVS is a big pain for me) like
the problem compiling the CVS version, problem with the listing of acceptors
in the -hbn .ndx file, and insufficient documentation.

Also available in: Atom PDF