Project

General

Profile

Feature #1016

Add TIP5P-E water model

Added by Jellby empty over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
uncategorized
Close

Description

It's very easy, just add a new atom type (in OPLS-AA force-field):

opls_118E OW 8 15.99940 0.000 A 3.09700e-01 7.44752e-01 ; J. Chem. Phys. 120 (2004) 6085-6093

and change tip5p.itp to use opls_118E instead of opls_118.

The TIP5P-E model is supposed to correct the TIP5P model for use with Ewald summation instead of simple cut-off.

Associated revisions

Revision 8103e94f (diff)
Added by Rossen Apostolov almost 3 years ago

Added tip5pe water model to oplsa.

The model introduces a small modification to the tip5p model
to reproduce better experimental data for simulations using
Ewald summation.

Reference publication J. Chem. Phys. 120 (2004) 6085-6093.

Fixes #1016.

Change-Id: I1afba614d65d1e4e8eb8594e99eea41e31f1e391

History

#1 Updated by Roland Schulz over 4 years ago

Could you upload the change to gerrit.gromacs.org?

#2 Updated by Jellby empty over 4 years ago

I guess I could, but it is quite inconvenient to be forced to install all the source code (and I'd have to find out how to do it first) for just a simple addition. I think it would be much easier for a more regular developer to upload the change (I don't care about authorship).

By the way, I mean to copy the tip5p.itp file into a new one, and modify the new one, the current tip5p.itp file is OK.

#3 Updated by Roland Schulz over 4 years ago

Sure it takes longer but only once. And it helps the core developers a lot because it allows you to fix any problems with it yourself. If I would upload it for you and someone points out problems with it, I would have to fix it or have to ask you to send me something which I then need to upload. So we usually don't have the time to add features unless they are uploaded to gerrit.

#4 Updated by Gerrit Code Review Bot almost 3 years ago

Gerrit received a related patchset '1' for Issue #1016.
Uploader: Rossen Apostolov ()
Change-Id: I1afba614d65d1e4e8eb8594e99eea41e31f1e391
Gerrit URL: https://gerrit.gromacs.org/3563

#5 Updated by Rossen Apostolov almost 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#6 Updated by Erik Lindahl almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF