Project

General

Profile

Bug #1022

pdb2gmx n-terminus

Added by Drazen Petrov over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

in gromos force fields, PRO-NH n-terminus type is missing a dihedral term between CD-N-CA-C atoms.

Associated revisions

Revision 05efeff7 (diff)
Added by Erik Lindahl almost 3 years ago

Fixed GROMOS assignment of PRO-NH terminus torsions

This patch also adjusts the parameters for torsions
over N-CA bonds in the termini, according to
suggestions by Justin Lemkul & Drazen Petrov.

Fixes #1022.

Change-Id: Ib00d69eeddf924b1e7e2de33475d774d7da54899

History

#1 Updated by Roland Schulz over 4 years ago

Could you give some more detail? Please explain what the correct dihedral term is (ideally with citation) and a pointer to the line and file where it is missing. Also please say in what Gromacs version it is wrong. Ideally you could upload a fixed version to gerrit.gromacs.org.

#2 Updated by Roland Schulz over 4 years ago

  • Status changed from New to Feedback wanted

#3 Updated by Drazen Petrov over 4 years ago

This is more of a gromos force field problem than a gromacs problem, meaning, the error is in the n-terminus database file of different gromos force fields (*n.tdb files) and the error is in all versions.
The problem is that pdb2gmx produces topology file with a missing dihedral when PRO-NH type of n-terminus is chosen. Simply by comparing PRO-NH to PRO-NH2 type (in the n-terminus database file "*n.tdb"), one can see that the latter has H1-N-CA-C dihedral term, which is missing in the former.
I have written that CD-N-CA-C dihedral term is missing because a heavier atom is usually used if possible, which is the case for proline. However, to be consistent with the PRO-NH2 type, it is probably better to add H-N-CA-C dihedral. The correct term depends on the force field in question (e.g. correct term for gromos45a3 is gd_14).

I could not find where to upload fixed files on gerrit.gromacs.org. In principle, I could send it via email.

Also, in the meanwhile, I have found another problem with pdb2gmx related to gromos force fields. CA atom of the fist residue in a produced topology file is not in the same charge group as the n-terminal nitrogen and hydrogen atoms. Therefore, the sum of partial charges in the first and the second change group is a non-integer number.

#4 Updated by Justin Lemkul over 4 years ago

I looked into this a little bit myself and I'd like to add a bit more information. In fact, pdb2gmx does write a dihedral term for N-CA for both termini; the problem is that for PRO-NH, there are no associated parameters (should be gd_39 in 53A6). PRO-NH2+ writes a dihedral term correctly, but it appears as if this was added later as a workaround. If one comments the dihedral line for PRO-NH2+ in the .n.tdb file out, it produces the same as PRO-NH (writing a dihedral for CD-N-CA-CB). The H-N-CA-C, CD-N-CA-C, and CD-N-CA-CB dihedrals would all be equivalent, so only one needs to be assigned.

There is a compounded problem, in that the .n.tdb file assigns gd_29 instead of gd_39. I think a universal solution is to assign the dihedral as CD-N-CA-C in the .rtp file for [PRO] and remove the added [dihedral] in the .n.tdb file. The .rtp entry was built from the original GROMOS force field files, which specify it as (C)-N-CA-C, but that obviously is causing problems. Any -N-CA dihedral should have the same parameters, irrespective of atoms i and l.

As for the charge group issue, I can't say what is right, but the GROMOS force fields appear to be the only ones that add an extra field in the [replace] directive that seems to indicate the CA atom is placed in a new charge group. This behavior is not described in the manual. Roland, any ideas? I can make the appropriate fixes in the git repo and submit to gerrit, would just prefer to do one fix rather than two tiny ones. The dihedral issue seems to be easy to fix, I'm just not so sure about the charge group thing.

#5 Updated by Roland Schulz over 4 years ago

  • Status changed from Feedback wanted to In Progress
  • Assignee set to Justin Lemkul

David has added those extra zeros in commit e635d411415a65b2623ddf26e3be66521436f557. Maybe he can explain it.

#6 Updated by Justin Lemkul over 4 years ago

It would seem to me that those zeros belong in the [add] block, where the manual indicates an optional charge group field. I'm adding David to the watchers here, hopefully he can give me an indication of the proper resolution.

#7 Updated by Drazen Petrov over 4 years ago

I have completely missed that the dihedral term in question is actually incorrect for the PRO-NH2+ type. So, it should be gd_19 for 45a3, not gd_14 as I suggested.

I think that assigning CD-N-CA-C dihedral for PRO in the rtp file is not a very good solution because it is redundant, since every amino acid, including PRO, has -C N CA C dihedral already assigned, which is the same dihedral. Probably the easiest would be to assign CD-N-CA-C dihedral for both PRO-NH and PRO-NH2+ types in the n.tdb file.

#8 Updated by Rossen Apostolov about 3 years ago

  • Target version set to 4.6.x
  • Affected version set to 4.5.1

David, what do you think about the charge group issue?

#9 Updated by Rossen Apostolov about 3 years ago

  • Assignee changed from Justin Lemkul to David van der Spoel
  • Target version changed from 4.6.x to 4.6.6

#10 Updated by Gerrit Code Review Bot about 3 years ago

Gerrit received a related patchset '1' for Issue #1022.
Uploader: Erik Lindahl ()
Change-Id: Ib00d69eeddf924b1e7e2de33475d774d7da54899
Gerrit URL: https://gerrit.gromacs.org/3657

#11 Updated by Erik Lindahl about 3 years ago

  • Status changed from In Progress to Fix uploaded

#12 Updated by Gerrit Code Review Bot almost 3 years ago

Gerrit received a related patchset '1' for Issue #1022.
Uploader: Rossen Apostolov ()
Change-Id: Ib00d69eeddf924b1e7e2de33475d774d7da54899
Gerrit URL: https://gerrit.gromacs.org/3678

#13 Updated by Erik Lindahl almost 3 years ago

  • Status changed from Fix uploaded to Resolved

#14 Updated by Erik Lindahl almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF