Project

General

Profile

Bug #1042

mdrun de-rails over classic water/0192 with GPU support compiled in, but not active

Added by Gernot Ziegler about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When trying to run the latest release-4-6 git source

C:\Users\gziegler.NVIDIA.COM\src\gromacs>cmake -DGMX_CPU_ACCELERATION=None -DGMX_GPU=ON -DGMX_FFT_LIBRARY=fftpack
[attaching CMakeCache.txt]

and running mdrun in the most simple way
G:\gromacs_testdata\water\0192>c:mdrun

on a topol.tpr generated from the water/0192 input file pme.mdp, I get (both with and without GMX_EMULATE_GPU set):

Back Off! I just backed up md.log to ./#md.log.20#
Reading file topol.tpr, VERSION 4.6-dev-20121120-0290409 (single precision)
Changing nstlist from 10 to 40, rlist from 1 to 1.159

Using 1 MPI thread
Using 8 OpenMP threads

WARNING! Binary not matching hardware - you are likely losing performance.
Acceleration most likely to fit this hardware: SSE4.1
Acceleration selected at GROMACS compile time: None

1 GPU detected:
#0: NVIDIA GeForce GTX 680, compute cap.: 3.0, ECC: no, stat: compatible

Emulating a GPU run on the CPU (slow)
Using plain C 8x8x8 non-bonded kernels

Back Off! I just backed up ener.edr to ./#ener.edr.20#
starting mdrun 'Water'
500 steps, 1.0 ps.

step 15: Water molecule starting at atom 1516 can not be settled.
Check for bad contacts and/or reduce the timestep if appropriate.

Back Off! I just backed up step15b.pdb to ./#step15b.pdb.11#

Back Off! I just backed up step15c.pdb to ./#step15c.pdb.11#
Wrote pdb files with previous and current coordinates

step 16: Water molecule starting at atom 13825 can not be settled.
Check for bad contacts and/or reduce the timestep if appropriate.

[etc.]

CMakeCache.txt (60.4 KB) CMakeCache.txt Gernot Ziegler, 11/21/2012 12:25 AM
topol.tpr (4.41 MB) topol.tpr Gernot Ziegler, 11/21/2012 12:25 AM
pme.mdp (940 Bytes) pme.mdp Gernot Ziegler, 11/21/2012 12:25 AM
gromacs_sse_vs_32bitbuildonwin64.png (227 KB) gromacs_sse_vs_32bitbuildonwin64.png Gernot Ziegler, 12/11/2012 03:04 PM

Associated revisions

Revision 928ff177 (diff)
Added by Berk Hess about 5 years ago

fixed GPU pair-search with GMX_CPU_ACCELERATION=None

Fixes #1042 and fixes #1062

Change-Id: I95ed242823aa1c108fc6c26bedc88062a0cd81d7

History

#1 Updated by Szilárd Páll about 5 years ago

  • Status changed from New to In Progress

Note: the water 192k system is a simple box of pure water used for GPU benchmarking.

#2 Updated by Szilárd Páll about 5 years ago

I can confirm that settle errors show up from step 15 both with GPU and with GPU emulation runs, but not with CPU-only runs.

#3 Updated by Berk Hess about 5 years ago

  • Status changed from In Progress to Feedback wanted

This runs fine for me with the latest git, equivalent to beta2. Maybe this was due to a bug with got fixed in the meantime (have no clue what that could have been though). Can you try if you can still reproduce this with the latest git?

#4 Updated by Roland Schulz about 5 years ago

Given that this is with GMX_CPU_ACCELERATION=None this is probably the same problem as #1062.

#5 Updated by Gernot Ziegler about 5 years ago

At least on my side, it still doesn't work - maybe it has to do with the fact that we are building a Win32 binary for a Win64 installation (and driver)?
There is no Win64 target for GROMACS in Windows, or is there?

#6 Updated by Roland Schulz about 5 years ago

Yes you can build 64bit Windows binaries. You need to call cmake with "-G Visual Studio 10 Win64" (or what ever VS version you are using).

#7 Updated by Berk Hess about 5 years ago

I missed the acceleration=none. This is then indeed the same issue as 1062.
Note that turning off cpu acceleration leads to a factor 3 performance loss, also with GPU!

#8 Updated by Gernot Ziegler about 5 years ago

Roland: Thanks for that option, it allows me to generate 64-bit builds. I must have missed it in the documentation?
Unfortunately, even though the code compiles, now it just hangs indefinitely - both grompp do (after "Set rlist, assuming 4x atom pair list") and mdrun (last messages "Changing nstlist from 10 to 40").

#9 Updated by Gernot Ziegler about 5 years ago

Szilard: Can you still replicate my original issue?
Berk: I am not worried about performance yet, I would just like to get the right result at the moment, using the GPU (so that I can use NSight on it, that was my original goal)

#10 Updated by Roland Schulz about 5 years ago

It isn't in our documentation but it is in the cmake documentation. We are not sure how much of the cmake documentation we should replicate into ours.

How exactly did you compile. I just tested it and it works fine for me.
I used VS2010SP1 (make sure you have SP1 - otherwise it could be that - VS2012 should work too), CUDA5 (CUDA4.2 should work too but I haven't tested it). No cmake options other than fftpack (cmake .. -DGMX_FFT_LIBRARY=fftpack).

#12 Updated by Gernot Ziegler about 5 years ago

Berk: thank you! Problem fixed. :-)

Roland: I understand; for a Linux developer like me, it wasn't obvious to use -G. Maybe you can make CMake fail if no generator is specified? The problem that made this so frustrating (and that's the last bug remaining, though not very important) is that if CMake chooses to create a 32bit build, including support for SSE2 or SSE4 on my Win64 system, compilation fails for some alignment issues (screenshot attached). But that is not important, because I can now create a 64bit build instead using the generator. Thanks for the hint!

#13 Updated by Berk Hess about 5 years ago

  • Status changed from Feedback wanted to Closed

#14 Updated by Roland Schulz about 5 years ago

I asked that the -G to be included in the installation guide. Also I opened a new bug #1068 for the align error. Thanks for reporting.

Also available in: Atom PDF