Project

General

Profile

Bug #1116

incorrect volume with MTTK + particle decompostion

Added by Berk Hess over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Affected version - extra info:
4.5
Affected version:
Difficulty:
uncategorized
Close

Description

In version 4.5 running MTTK pressure coupling with particle decomposition give a too large volume. The error seems to roughly scale with the number of nodes. With domain decomposition it is correct.
In 4.6 I can't reproduce this, so it seems to be fixed.
We should find and backport this fix to 4.5, or disable MTTK with particle decomposition.

Associated revisions

Revision b77fa706 (diff)
Added by Michael Shirts about 4 years ago

Some changes for md-vv extracted from 4.6

a. Fixes for the pressure in MTTK with constraints + dispersion + rerun
  • Dispersion is correctly added in rerun
  • COM motion is removed only on the second half of the timestep.
  • Now can do md-vv + rerun with multiple threads.
  • Now gives exact kinetic energy reruns for everything except MTTK, where the iterative algorithm
    makes exact kinetic energy impossible when nstpcouple == 1.

b. md-vv works with v-rescale and berendsen

c. Fixes a bug when pressure control in md-vv when nstcalcenergy is not a
multiple of nstpcouple or nsttcouple. This bug results in boxes slowly
expanding to unphysical sizes because the virial is
neglected in the second half of the md-vv calculation.

Also discovered that as part of the bug, global energies were being communicated
where they did not need to be when nstpcouple and nsttcouple are > 1 in the case
of md-vv, so redid some of the iteration counting and global communication to fix
this all together. In the process, this simplified some of the iteration counting.

Should fix bugs #1116, #1012, #1000, #1129 in redmine.

Change-Id: I1b628d03ab588c29fef2b8789e61254da49c2b6f

History

#1 Updated by Berk Hess over 4 years ago

Forgot to add that this was noticed for a system with SHAKE (H-only) constraints.
The constraint/virial coupling is a likely source of error here.

#2 Updated by Michael Shirts over 4 years ago

  • Target version set to 4.5.6

I'm tracking down the last 4.6 bugs over the next 1-2 days but I will go back afterwards and identify where to backport them.

#3 Updated by Mark Abraham over 4 years ago

OK. In practice, there will be a window after 4.6 and before 4.5.6 because I'm taking a long weekend. This could go in at that time. Otherwise I'll bump the target version to 4.5.7.

#4 Updated by Mark Abraham over 4 years ago

  • Status changed from New to In Progress

#5 Updated by Mark Abraham over 4 years ago

  • Target version changed from 4.5.6 to 4.5.7

Draft https://gerrit.gromacs.org/#/c/2101/ should solve this

#6 Updated by Roland Schulz over 4 years ago

Drafts are not visible to anyone but reviewers. Never mind if that was the intention, just saying in case you didn't know.

#7 Updated by Michael Shirts over 4 years ago

Roland Schulz wrote:

Drafts are not visible to anyone but reviewers. Never mind if that was the intention, just saying in case you didn't know.

Yes. It's now been moved to the main page.

#8 Updated by Mark Abraham about 4 years ago

  • Status changed from In Progress to Resolved
  • Affected version set to 4.5.6

#9 Updated by Rossen Apostolov over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF