Project

General

Profile

Bug #1136

genion and g_disre segv with verlet scheme tpr files

Added by Berk Hess about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
analysis tools
Target version:
Affected version - extra info:
4.6
Affected version:
Difficulty:
uncategorized
Close

Description

All tools that call init_forcerec with a tpr file with the Verlet cut-off scheme stop with a segmentation fault.
The problem is that hwinfo has not been initialized (even if it isn't really used).

Associated revisions

Revision 856c65fe (diff)
Added by Berk Hess about 4 years ago

fixed segv in init_forcerec with fr->hwinfo=NULL

This caused genion and g_disre to segv with the Verlet scheme.
Fixes #1136

Change-Id: I9059b0e108c80ea86567a568e9f488b4db500eee

History

#1 Updated by Berk Hess about 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF