Project

General

Profile

Bug #1156

mdrun -nt > 1 crashes with old tpr

Added by David van der Spoel over 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

As reported here http://lists.gromacs.org/pipermail/gmx-users/2013-February/078961.html mdrun 4.6 crashes with more than one thread when run with a particular old tpr file. Initial debugging points to initiation of new data structures that are not present in the old tpr file (line 569 below).

567 block_bc(cr, fep->n_lambda);
568 snew_bc(cr, fep->all_lambda, efptNR);
569 nblock_bc(cr, efptNR, fep->all_lambda);

It runs with one thread.

gmx_workload2.tpr (3.09 MB) gmx_workload2.tpr David van der Spoel, 02/23/2013 08:19 AM

Associated revisions

Revision 8dfabe50 (diff)
Added by Michael Shirts over 6 years ago

fix imcompatibility with tpr vers<64 with free energy option

should fix to redmine #1156

Change-Id: I6e60f1efbb03bf460009b8bc59f80f2e0e15bf44

Revision 23172124 (diff)
Added by Michael Shirts over 6 years ago

fix imcompatibility with tpr vers<64 with free energy option

should fix to redmine #1156

Change-Id: I6e60f1efbb03bf460009b8bc59f80f2e0e15bf44

History

#1 Updated by David van der Spoel over 6 years ago

  • Target version set to 4.6.1

#2 Updated by Peter Kasson over 6 years ago

I have also encountered this problem on multiple TPR files FWIW.

#3 Updated by David van der Spoel over 6 years ago

Additional information: the routine

static void do_expandedvals(t_fileio *fio, t_expanded *expand, t_lambda *fepvals, gmx_bool bRead, int file_version)

is only called for new files (tpx_version > 79) therefore the rest will be initialized with NULL or 0.

#4 Updated by Michael Shirts over 6 years ago

Looks like it's probably my fault, then. I'll see what I can come up with to fix.

#5 Updated by Michael Shirts over 6 years ago

Posted a fix. I believe this only affects tprs with version < 64.

#6 Updated by Berk Hess over 6 years ago

  • Assignee set to Michael Shirts

Is this a duplicate of #1131?

#7 Updated by Daniel Wang over 6 years ago

Michael Shirts wrote:

Posted a fix. I believe this only affects tprs with version < 64.

Could you send me the patch? I prefer to use gromacs4.6 because it runs slightly faster than 4.5.
Here is my email address:
Thanks a lot:)

#8 Updated by Justin Lemkul over 6 years ago

Daniel Wang wrote:

Michael Shirts wrote:

Posted a fix. I believe this only affects tprs with version < 64.

Could you send me the patch? I prefer to use gromacs4.6 because it runs slightly faster than 4.5.
Here is my email address:
Thanks a lot:)

You can download a patch to the development code at https://gerrit.gromacs.org/#/c/2196/.

#9 Updated by Mark Abraham over 6 years ago

  • Status changed from New to Accepted
  • Affected version set to 4.6

#10 Updated by Mark Abraham over 6 years ago

  • Status changed from Accepted to In Progress

#11 Updated by Mark Abraham over 6 years ago

  • Status changed from In Progress to Resolved

#12 Updated by Rossen Apostolov almost 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF