Project

General

Profile

Bug #1174

Error when extending simulation

Added by Sebastian Waltz about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
4.6
Affected version:
Difficulty:
uncategorized
Close

Description

when I try to extend on of my simulations with

mdrun -deffnm pdz_cis_NVT_disre_equi_3 -cpi pdz_cis_NVT_disre_equi_3.cpt -append

I get the following error

Fatal error:
Count mismatch for state entry disre_rm3tav, code count is 0, file count is 13

I tried the same thing for a second simulation and get the same error.
I can extend this simulation by using tpbconv and the trr file without any errors.

All the best

Sebastian

pdz_cis_NVT_disre_equi_3.tpr (788 KB) Sebastian Waltz, 03/05/2013 03:33 PM

pdz_cis_NVT_disre_equi_3.cpt (326 KB) Sebastian Waltz, 03/05/2013 03:33 PM

pdz_cis_NVT_disre_equi_3_prev.cpt (326 KB) Sebastian Waltz, 03/05/2013 03:33 PM

pdz_cis_NVT_disre_equi_3.log View (109 KB) Sebastian Waltz, 03/05/2013 03:33 PM

Associated revisions

Revision e6728b96 (diff)
Added by Mark Abraham over 3 years ago

Fixed reading history_t from checkpoint

The use of the wrong reading function prevented reading any checkpoint
file with distance restraints, (and probably any with orientation
restraints, too) because the stored lengths of the arrays could not be
read.

Additionally, the way a t_state is allocated on the stack and most of
the GROMACS code base assumes structures have been allocated on the
heap (and set to zero) by snew() makes the problem worse. Noted that
this is evil and must go away some time.

Fixes #1174

Change-Id: Ic8240f80c17272a1499421233689ed4b2c640ba3

History

#1 Updated by Justin Lemkul about 4 years ago

  • Assignee deleted (Justin Lemkul)

Not my ballpark, sorry.

#2 Updated by Justin Lemkul about 4 years ago

  • Target version changed from 4.6 to 4.6.2

#3 Updated by Justin Lemkul about 4 years ago

  • Affected version - extra info set to 4.6

#4 Updated by Mark Abraham almost 4 years ago

  • Status changed from New to Accepted
  • Assignee set to Mark Abraham
  • Target version changed from 4.6.2 to 4.6.3
  • Affected version set to 4.6

Reproduced

#5 Updated by Mark Abraham almost 4 years ago

  • Status changed from Accepted to In Progress

#6 Updated by Mark Abraham almost 4 years ago

  • Status changed from In Progress to Fix uploaded

https://gerrit.gromacs.org/2350 will permit simulations with distance restraints (and, I assume, orientation restraints) to be extended. And also permit gmxcheck to work. And all that even from earlier 4.6 checkpoint files.

#7 Updated by Mark Abraham over 3 years ago

  • Target version changed from 4.6.3 to 4.6.4

#8 Updated by Mark Abraham over 3 years ago

  • Status changed from Fix uploaded to Resolved
  • % Done changed from 0 to 100

#9 Updated by Mark Abraham over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF