Project

General

Profile

Bug #118

problem of g_energy -nmol

Added by qiaobf empty about 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
High
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When using the g_energy -nmol to calculate the energy, only the Bond,
Angle,Potential terms are right,while the LJ, Coulomb, Total-Energy give the
same value as withoug -nmol.

See the following two tests.

Test 1.

g_energy -f md3.edr

Energy Average RMSD Fluct. Drift Tot-Drift
-------------------------------------------------------------------------------
Bond 1370.47 64.952 64.8116 0.0295732 14.7866
Angle 3541.69 99.9164 99.9059 0.0100593 5.02964
LJ-(SR) 3601.66 151.232 131.574 -0.516572 -258.287
Coulomb
(SR) -10883 143.406 134.139 -0.351347 -175.674
Potential -30962.9 304.081 265.607 -1.0257 -512.85
Total-Energy -22436.1 287.863 245.635 -1.03989 -519.945

g_energy -nmol 115 -f md3.edr

Energy Average RMSD Fluct. Drift Tot-Drift
-------------------------------------------------------------------------------
Bond 11.9171 0.5648 0 0.0295732 14.7866
Angle 30.7973 0.868838 0 0.0100593 5.02964
LJ-(SR) 3601.66 151.232 131.574 -0.516572 -258.287
Coulomb
(SR) -10883 143.406 134.139 -0.351347 -175.674
Potential -269.242 2.64418 0 -1.0257 -512.85
Total-Energy -22436.1 287.863 245.635 -1.03989 -519.945

Test 2.

g_energy -f md3.edr

Energy Average RMSD Fluct. Drift Tot-Drift
-------------------------------------------------------------------------------
Bond 27255.4 288.517 287.731 0.147486 73.7433
Angle 30206.8 299.196 299.151 0.0361126 -18.0563
LJ
(SR) 27021.1 1153.88 1015.89 -3.7911 -1895.55
Coulomb
(SR) -116585 1327.11 1120.39 -4.92805 -2464.03
Potential -271448 2889.94 2444.54 -10.6792 -5339.61
Total-Energy -183054 2912.13 2478.91 -10.588 -5293.99

g_energy -nmol 981 -f md3.edr

Energy Average RMSD Fluct. Drift Tot-Drift
-------------------------------------------------------------------------------
Bond 27.7833 0.294105 0 0.147486 73.7433
Angle 30.7919 0.304991 0 0.0361126 -18.0563
LJ
(SR) 27021.1 1153.88 1015.89 -3.7911 -1895.55
Coulomb
(SR) -116585 1327.11 1120.39 -4.92805 -2464.03
Potential -276.705 2.94591 0 -10.6792 -5339.61
Total-Energy -183054 2912.13 2478.91 -10.588 -5293.99

History

#1 Updated by David van der Spoel almost 13 years ago

This is a duplicate of bug 76 which was fixed already in CVS.

Also available in: Atom PDF