Project

General

Profile

Bug #12

Forces between frozen particles contribute to pressure.

Added by Ramon Garcia about 15 years ago. Updated about 15 years ago.

Status:
Closed
Priority:
Low
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

If two particles are frozen, their force should not contribute to pressure. It
does currently in Gromacs.

History

#1 Updated by Erik Lindahl about 15 years ago

Frozen means a particle is not moved in the update algorithm, but all interactions are still calculated for it
(and it should thus contribute to pressure - imagine the case where just one particle is frozen). To avoid
interactions and pressure, use exclusions or exclusion groups.

#2 Updated by Ramon Garcia about 15 years ago

This is the opposite of what the user expects. Futhermore, it produces broken
results with a barostat. As those interactions may create high pressure, the
barostat makes the system expand, but the frozen particles do not move. This
causes the system to explode.

#3 Updated by Erik Lindahl about 15 years ago

Again, this is not a bug - the code behaves as intended and documented.
The proper way to deal with the problem described is exclusions. You could argue that it would be nice if
grompp created this exclusion automatically, but that's a discussion for the mailing list, not the
bugtracker.

#4 Updated by Ramon Garcia about 15 years ago

OK.

I will try to implement this feature if I have time.

Also available in: Atom PDF