Project

General

Profile

Bug #1249

no-PBC no-cutoff is broken with SIMD group kernels in 4.6.1

Added by David van der Spoel over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

From gmx-users 2013-05-13

So I think I figured out what was causing the discrepancy of Charmm27 energies between gromacs and NAMD. It appears that it's related to the gromacs version: energies from 4.5.7 and NAMD match very well while 4.6.1 gives energies that are different from both 4.5.7 and NAMD.

Here are the results form my tests on POPC membrane:

===============================
  BOND        ANGLE        DIH         IMP       COUL        LJ          POT
gromacs-4.5.7/gromacs.log
  1539.120    3111.902    1250.540      16.284   -1705.306   -1219.345    2993.188

gromacs-4.6.1/gromacs.log
  1539.120    3111.902    1250.540      16.284   -5997.992     350.084     269.945

namd-2.9/namd.out
  1539.116    3111.920    1250.542      16.284   -1705.307   -1219.343    2993.211
===============================

I think this could be due to either 1) the simulation setup should be different between 4.5.7 and 4.6.1 when running single point calculations, or 2) my 4.6.1 compilation is not correct (although all regression tests passed), or 3) there is a bug somewhere.

I'll attach a script that automates the comparison between GROMACS and NAMD in a separate post (it will make this post > 50kB). If you run it and got similar/different results as mine, I'll be happy to know. Also any comment on the simulations setup is highly appreciated.

Reza

compare3.sh (3.96 KB) compare3.sh The script for automating the comparison Reza Salari, 05/14/2013 07:16 PM
memb_nowat.pdb (393 KB) memb_nowat.pdb Input PDB File Reza Salari, 05/14/2013 07:16 PM
mdpfile.mdp (218 Bytes) mdpfile.mdp MDP file Reza Salari, 05/14/2013 07:16 PM
par_all27_prot_lipid.prm (179 KB) par_all27_prot_lipid.prm Charmm27 Par file used for the NAMD tests Reza Salari, 05/14/2013 07:16 PM

Related issues

Related to GROMACS - Feature #1095: Fix all-vs-all kernelsIn Progress2012-12-28
Related to GROMACS - Bug #1134: gromacs 4.6 GB/SA problem and poor performanceClosed2013-01-27

Associated revisions

Revision 6a8acbaa (diff)
Added by Mark Abraham over 4 years ago

Work around for correct treatment of all-vs-all

Neither C or accelerated all-vs-all kernels work in 4.6. The group
SIMD kernels do not work either. The non-accelerated kernel is OK,
though.

Fixes #1249 (for certain values of "fixes"), refs #1095

Change-Id: Id52c0ba110aa915e77859585c2cbfd4d529fe3ca

Revision bba8adcd (diff)
Added by Berk Hess over 2 years ago

Reenabled SIMD kernels without cut-offs

In 4.6 there was a bug that caused incorrect results with group scheme
SIMD kernels with systems without cut-offs. This seems to have been
resolved already in 5.0.
Refs #1249.

Change-Id: I86c2b2ae097769472c1748e6e03a673a58a938eb

History

#1 Updated by Mark Abraham over 4 years ago

  • Description updated (diff)

#2 Updated by Mark Abraham over 4 years ago

Original report had mdp file with ns_type       = simple which would be my suspect

#3 Updated by Reza Salari over 4 years ago

I attached the input files (pdb and mdp) that I used for the tests. I also attached the automated script plus the charmm27 par file used for the NAMD runs.

#4 Updated by David van der Spoel over 4 years ago

I get the same energies as you do in 4.5.7, but in 4.6.1 the coulomb and lennard jones are zero, but not the 1-4. This happens with both nstype = simple and grid.

#5 Updated by Berk Hess over 4 years ago

  • Assignee set to Erik Lindahl
  • Priority changed from High to 7

In Gromacs the 4.6 release branch:
No pbc, no cut-off's always gives me no non-bonded interactions at all.
With pbc and a cut-off of 12 nm, the group scheme x86 SIMD kernels give incorrect energies.
Setting GMX_NOOPTIMIZEDKERNELS gives correct results. The Verlet scheme also gives correct results.

So there seem to be 2 serious bugs:
1) pbc=no skips all non-bonded interactions
2) group SIMD kernels give incorrect results for this system.

#6 Updated by Mark Abraham over 4 years ago

Email from Erik notes he plans to try to fix this tomorrow. We will hold 4.6.2 (again) for this.

#7 Updated by Mark Abraham over 4 years ago

... or hack in some fatal errors as I have done recently for things like FE+GB

#8 Updated by Mark Abraham over 4 years ago

Looks like it's hack time

#9 Updated by Mark Abraham over 4 years ago

Hack fix in Gerrit https://gerrit.gromacs.org/#/c/2399/. Now produces correct results and avoids the known failing cases.

Erik still hopes to have time to fix the issue with the SIMD group kernels, but probably the all-vs-all kernels will not be fixed any time soon.

#10 Updated by Mark Abraham over 4 years ago

  • Subject changed from 4.6.1 does not reproduce 4.5.7 energies with CHARMM FF to no-PBC no-cutoff is broken with SIMD group kernels in 4.6.1

Updated subject line to reflect the real problem

#11 Updated by Mark Abraham over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#12 Updated by Mark Abraham over 4 years ago

  • Category set to mdrun
  • Status changed from Resolved to In Progress
  • Priority changed from 7 to Normal
  • Target version changed from 4.6.2 to 4.6.3

Erik is still working on proper fixes

#13 Updated by Mark Abraham over 4 years ago

  • Target version changed from 4.6.3 to 4.6.x

#14 Updated by Rossen Apostolov over 3 years ago

  • Status changed from In Progress to Resolved

#15 Updated by Rossen Apostolov over 3 years ago

  • Status changed from Resolved to Closed

#16 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '26' for Issue #1249.
Uploader: Berk Hess ()
Change-Id: I90b1ca303fc0cfd000cc7b6148f4882e0b4471b6
Gerrit URL: https://gerrit.gromacs.org/4364

#17 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1249.
Uploader: Berk Hess ()
Change-Id: I86c2b2ae097769472c1748e6e03a673a58a938eb
Gerrit URL: https://gerrit.gromacs.org/4486

Also available in: Atom PDF