Project

General

Profile

Task #1290

OpenMPI 1.4.3 in Ubuntu 12.04 can produce simulation crashes with any version of GROMACS

Added by Mark Abraham over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Difficulty:
uncategorized
Close

Description

While testing #1254, we observed that the default OpenMPI 1.4.3(-2.1ubuntu) in Ubuntu 12.04 LTS (precise) sometimes crashes with GROMACS versions from the whole 4.x series. We believe this is a memory corruption issue in that version of OpenMPI, perhaps in communicator splitting, but have not been able to identify from the OpenMPI 1.4 branch commit logs a patch that fixes it. The OpenMPI 1.5.4-0ubuntu1 package seems to work OK, and we recommend people use it when compiling GROMACS from source. We also recommend people generally avoid the OpenMPI 1.4.x branch (which is years old and will make no new releases).

The gromacs-openmpi package (4.5.5-1) in precise depends on the buggy version of OpenMPI, as does a lot of other packages (including octave, parpack). A proper solution for it would either involve
  • identifying the OpenMPI fix and backporting it to the 1.4.3 package, or
  • bumping the required libopenmpi version to 1.5 (if it is possible to have both libopenmpi versions installed on the same system).

This information is provided as a "public safety" message for people searching for the reason for such an irreproducible crash. We're not planning to try to identify the bug in a years-old version of MPI. If someone wishes to attempt to solve the issue, to (often) reproduce the crash, use

mpirun -np 24 mdrun_mpi -npme 6 -s waterbox-sim.tpr

with the attached version 4.5.5 .tpr.

From the point of view of GROMACS, there is no issue to solve, so the status is "resolved" in our bug tracker.

waterbox-sim.tpr (412 KB) waterbox-sim.tpr Mark Abraham, 06/25/2013 06:27 PM

Related issues

Related to GROMACS - Bug #1254: a likely mdrun memory corruption/race conditionClosed05/17/2013

History

#1 Updated by Mark Abraham over 6 years ago

  • Description updated (diff)

#2 Updated by Rossen Apostolov about 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF