Project

General

Profile

Bug #130

mdrun ignores atoms on single processor

Added by Erik Marklund almost 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

mdrun (3.3.99_dev) ignores most atoms in my system when un on a single
processor. My system contains 107272 atoms, mostly water, but mdrun says "There
are: 36224 Atoms" and immediatlely runs into SETTLE-problems. The latter is no
mystery, since the abscence of the 36225:th atom means that a water molecule is
lacking a hydrogen, and the vacuum patches caused by rest of the missing waters
may very well mess up SETTLE too.

I tried to run the simulation on 4 processors, and the whole problem was
circumvented for some reason.

I have several similar systems showing the same behaviour.

The trr-file was generated in the following way:
grompp -f posre.mdp\
-c $p/mdrun_run_em.gro\
-p $size\.top\
-n $size\_posre.ndx\
-po $p/grompp_run_posre.mdp\
-o $p/grompp_run_posre.tpr

and mdrun was started as follows:
mpirun -np 1 mdrun\
-s $p/grompp_run_posre.tpr\
-o $p/mdrun_run_posre\
-c $p/mdrun_run_posre\
-x $p/mdrun_run_posre\
-g $p/mdrun_run_posre\
-e $p/mdrun_run_posre\
-v

When running on four processors I added the -dd flag, and changed the mpirun
call to -np 4 of course.

Everything was done on our Opteron machines.

grompp_run_posre.tpr (14.3 MB) grompp_run_posre.tpr The run input file Erik Marklund, 02/02/2007 01:41 PM

History

#1 Updated by Erik Marklund almost 13 years ago

Created an attachment (id=106)
The run input file

#2 Updated by Erik Marklund almost 13 years ago

(In reply to comment #0)

mdrun (3.3.99_dev) ignores most atoms in my system when un on a single
processor. My system contains 107272 atoms, mostly water, but mdrun says "There
are: 36224 Atoms" and immediatlely runs into SETTLE-problems. The latter is no
mystery, since the abscence of the 36225:th atom means that a water molecule is
lacking a hydrogen, and the vacuum patches caused by rest of the missing waters
may very well mess up SETTLE too.

I tried to run the simulation on 4 processors, and the whole problem was
circumvented for some reason.

I have several similar systems showing the same behaviour.

The trr-file was generated in the following way:
grompp -f posre.mdp\
-c $p/mdrun_run_em.gro\
-p $size\.top\
-n $size\_posre.ndx\
-po $p/grompp_run_posre.mdp\
-o $p/grompp_run_posre.tpr

and mdrun was started as follows:
mpirun -np 1 mdrun\
-s $p/grompp_run_posre.tpr\
-o $p/mdrun_run_posre\
-c $p/mdrun_run_posre\
-x $p/mdrun_run_posre\
-g $p/mdrun_run_posre\
-e $p/mdrun_run_posre\
-v

When running on four processors I added the -dd flag, and changed the mpirun
call to -np 4 of course.

Everything was done on our Opteron machines.

PS
-dd 2 2 1 was used for the 4 processor run. Sorry about the lack of clarity.
DS

#3 Updated by Erik Marklund almost 13 years ago

I just started a run using 3.3.2b for grompp and mdrun, and it seems to be
working just fine.

#4 Updated by Erik Marklund almost 13 years ago

(In reply to comment #3)

I just started a run using 3.3.2b for grompp and mdrun, and it seems to be
working just fine.

I see that the bug is closed without any comment. I realize that my precious
comment might give the impression that mdun works just as it should, but the
problem arose in the 3.3.99_dev-version, the 3.3.2b-run was just for comparison.
That is why I now reopen the bug.

#5 Updated by Berk Hess almost 13 years ago

I forget the comment in my last comment.

I assume this bug was fixed by my commit of md.c on January 17.

Berk.

Also available in: Atom PDF