Project

General

Profile

Bug #1314

Expanded ensemble simulation died with fatal error: Something wrong in choosing new lambda state with a Gibbs move

Added by Michael Shirts about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

see:

http://gromacs.5086.x6.nabble.com/Expanded-ensemble-simulation-died-with-fatal-error-Something-wrong-in-choosing-new-lambda-state-withe-tp5010254.html

Basic problem: logic was failing for single precision because of round off errors. Solution: convert some of the intermediate arrays into double. Solution is being
tested and will be checked in in the next few minutes.

Associated revisions

Revision 0f52b0d0 (diff)
Added by Michael Shirts about 4 years ago

Fixing problem caused by overflow in expanded ensemble.

Basic problem: logic was failing for single precision because of round off errors.
Solution: convert some of the intermediate arrays into double.

Fixes redmine #1314

Change-Id: Id7e3771d257bbeebeed2f340593b817015a0cd4c

History

#1 Updated by Michael Shirts about 4 years ago

  • Status changed from New to Fix uploaded

OK fix uploaded.

#2 Updated by Mark Abraham about 4 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF