Project

General

Profile

Bug #1329

It is often useful to output the potential energy in the dhdl, rather than the total energy.

Added by Michael Shirts over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When mdrun -rerun'ing, the kinetic energy is frequently wrong. Thus, it is preferable to print the potential energy to dhdl rather than the total energy.

instead of being a boolean, proposed change is that dhdl-print-energy, instead of being boolean, takes options 'potential', 'total', 'yes' (same as 'total') and 'no'.

The change does not require a change in the tpr (gmx_bool is an int), and no defaults are changed, thus I propose to check this in for 4.6.

A fix will be checked in soon.

Associated revisions

Revision 8d30e53e (diff)
Added by Michael Shirts almost 3 years ago

Allow printing potential energies to dhdl.xvg file

Previously, only total energies were printed out to the dhdl.xvg
file. In many cases, it is more useful to print out just
the potential energies. For example, when doing mdrun -rerun,
and comparing to output run without rerun, the velocities may not
be identical, which makes it difficult to compare the total
energies between runs when computing free energies and other
observables. dhdl-print-energy can now be 'no', 'total',
or 'potential'. The alternative 'kinetic' should generally not
be needed, since that can be done analytically in all cases.

Backwards compatible in the .tpr since gmx_bool is an int. The
old false value will be interpreted as 'no', and the 'yes' value
as 'total' energy, which will reproduce the old behavior.

Fixes #1329

Change-Id: I16828ef07c46bcfc61fe03744cbf251c00160636

History

#1 Updated by Michael Shirts over 3 years ago

  • Status changed from New to Fix uploaded

Fix uploaded.

#2 Updated by Michael Shirts over 3 years ago

  • Target version changed from 4.6.5 to 4.6.4

#3 Updated by Mark Abraham over 3 years ago

  • Target version changed from 4.6.4 to 4.6.x

#4 Updated by Mark Abraham over 3 years ago

  • Target version changed from 4.6.x to 5.0

#6 Updated by Gerrit Code Review Bot almost 3 years ago

Gerrit received a related patchset '1' for Issue #1329.
Uploader: Erik Lindahl ()
Change-Id: I16828ef07c46bcfc61fe03744cbf251c00160636
Gerrit URL: https://gerrit.gromacs.org/3682

#7 Updated by Erik Lindahl almost 3 years ago

  • Status changed from Fix uploaded to Resolved

#8 Updated by Erik Lindahl almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF