Project

General

Profile

Bug #1353

g_lie computation results in 0 (or other obviosly wrong value depending on settings)

Added by Vytautas Vytas over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

$ g_lie -f md.edr -o lie.xvg -ligand SUA
In case I set options -Eqq -Cqq -Elj -Clj result is -(Eqq*Cqq+Elj*Clj) and again data in *.edr file is clearly ignored.

I provide my edr file too.

md.edr (20.1 KB) Vytautas Vytas, 10/07/2013 02:57 PM

lie.xvg (4.64 KB) Vytautas Vytas, 10/07/2013 06:53 PM

Associated revisions

Revision 4459cfff (diff)
Added by Justin Lemkul almost 3 years ago

Improvements to the g_lie help description.

Information was sparse, likely to avoid restating published
protocols, but some expansion was definitely warranted,
given the amount of questions that have recently been
posted to the mailing list and Redmine.

Refs #1353

Change-Id: Ib4057ae671ccac70061498b1d40ebcba84c497ee

History

#1 Updated by Justin Lemkul over 3 years ago

Please provide exact commands and corresponding output. Does the error persist in version 4.6.3? Development in the 4.5.x branch is minimal at this point and demonstrating an issue with a current version is more productive.

#2 Updated by Vytautas Vytas over 3 years ago

Same in 4.6.3
Here output to terminal:
http://pastebin.com/weCHgyiM
And I attach output file too.

#3 Updated by Justin Lemkul over 3 years ago

  • Status changed from New to Rejected

This is not a bug; you're simply not executing the calculations correctly. For LIE, you need the ligand and receptor as separate energygrps in the .mdp file to get the nonbonded interaction energies between the two. Your md.edr file does not have the correct terms. You then need to simulate the ligand in water to get the water-ligand interaction energies and supply them on the g_lie command line. Since you haven't done that, the command produces nothing useful. Wrong input, wrong output.

#4 Updated by Vytautas Vytas over 3 years ago

Your md.edr file does not have the correct terms

So g_lie should give error in that case instead of 0?

#5 Updated by Mark Abraham over 3 years ago

Indeed, it could do that. But its help text says that kind of thing. How could we have worded the help text so that you would have found the information you needed?

#6 Updated by Vytautas Vytas over 3 years ago

man g_lie only mentions:

g_lie computes a free energy estimate based on an energy analysis from. One needs an energy file with the following components: Coul (A-B) LJ-SR (A-B) etc.

Adding #3 to this whould be helpfull too.

#7 Updated by Justin Lemkul over 3 years ago

I will check in a more detailed description for g_lie. The existing (minimal) help description assumes the user is familiar with existing LIE methods, which are reviewed extensively elsewhere. I can understand the original intent of not wanting to duplicate information, but a bit of expansion can't hurt.

#8 Updated by Vytautas Vytas over 3 years ago

Thanks, I think I sorted it out now, but it really can cause confusion for new users.
Program giving error when failing to find necesarry input data instead of using zeroes and 'ligand' whould be really hepful for others.

#9 Updated by Justin Lemkul over 3 years ago

Proposed improvement checked into release-4-6 at https://gerrit.gromacs.org/#/c/2677/

#10 Updated by Mark Abraham over 3 years ago

Vytautas, what do you think of Justin's suggestion (see link)?

#11 Updated by Vytautas Vytas over 3 years ago

I like it.

#12 Updated by Justin Lemkul over 3 years ago

  • Status changed from Rejected to In Progress
  • Assignee set to Justin Lemkul

Working on a quick fix for input sanity check.

#13 Updated by Rossen Apostolov almost 3 years ago

  • Status changed from In Progress to Resolved

we close that one now.

#14 Updated by Rossen Apostolov almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF