Project

General

Profile

Bug #1381

generic group non-bonded kernel incorrect PME-switch and RF

Added by Berk Hess almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The electrostatic energies and forces in the generic non-bonded group kernel are off by orders of magnitude for both PME-switch and RF with potential-shift. Some combinations of PME-switch with LJ automatically use the generic kernels.
Related, I don't see why some combinations, e.g. PME-switch with LJ potential-shift, would not use the SIMD (or C) kernels.

History

#1 Updated by Erik Lindahl over 5 years ago

  • Status changed from New to Feedback wanted

This might have been related to the water optimization in the generic kernels, which should be fixed now. Please upload an example if there is still any discrepancy.

#2 Updated by Rossen Apostolov over 5 years ago

Berk, could you check if the issue is still present?

#3 Updated by Rossen Apostolov over 5 years ago

  • Assignee changed from Erik Lindahl to Berk Hess
  • Target version set to 4.6.6

#4 Updated by Erik Lindahl over 5 years ago

  • Status changed from Feedback wanted to Resolved

#5 Updated by Erik Lindahl over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF