Project

General

Profile

Bug #1414

grompp reinterprets pre-4.6 mdp files with group kernels to mean verlet kernels

Added by Erik Lindahl over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Low
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
5.0-beta2
Affected version:
Difficulty:
uncategorized
Close

Description

Grompp issues notes about nstlist settings and a fatal error if temperature coupling is not used with verlet-buffer-tolerance > 0. None of these tests should be applied when the user has selected group kernels.

Associated revisions

Revision be0769ab (diff)
Added by Mark Abraham over 3 years ago

Add helpful note about changed default behaviour

The kind of short .mdp file that might historically have been used for
tests, tutorials or benchmarks used to trigger the group cut-off
scheme up to and including 4.6, because it was either the only
behaviour or the default. Only one year later, the default has changed
to be the Verlet scheme, which might lead to confusion and/or invalid
comparisons. This note will hopefully help people start to understand
any differences.

Refs #1414

Change-Id: I34a2f1c17d4b58e14f81a95c1df3659f13a6cf24

History

#1 Updated by Erik Lindahl over 3 years ago

  • Subject changed from Verlet checks incorrectly applied in grompp for group kernels to grompp reinterprets pre-4.6 mdp files with group kernels to mean verlet kernels
  • Priority changed from Normal to Low

Not really a bug, but I'm keeping that selection since this is something that is likely to hit a few users - in particular those checking old benchmarks.

The cutoff-scheme setting was not introduced until Gromacs-4.6 a year ago; any mdp files prior to that do not list it, including a bunch of benchmarks. With gromacs-5.0, these are now silently reinterpreted to mean verlet. Well, it's not so silent in some cases since grompp does tests and frequently complains about the mdp file, but the cutoff scheme change is silent ;-)

Not critical for normal usage, but this will make some quite recent benchmarks seem a lot slower with Gromacs-5.0 unless the files are altered. The best solution would be if we could detect whether "cutoff-scheme" is listed in the mdp file and warn if it is not.

#2 Updated by Szilárd Páll over 3 years ago

IMO old files should behave as they did when created - as long as the respective feature is supported. While the results obtained with group and verlet schemes can be close, one can't just assume that they are freely interchangeable. Hence, I suspect most users would prefer to run the group scheme when providing an old tpr. To achieve this, we can just check the tpx version and with old tpr-s use the cutoff scheme which was default when the file was created.

#3 Updated by Gerrit Code Review Bot over 3 years ago

Gerrit received a related patchset '1' for Issue #1414.
Uploader: Mark Abraham ()
Change-Id: I34a2f1c17d4b58e14f81a95c1df3659f13a6cf24
Gerrit URL: https://gerrit.gromacs.org/2965

#4 Updated by Mark Abraham over 3 years ago

Erik Lindahl wrote:

Grompp issues notes about nstlist settings and a fatal error if temperature coupling is not used with verlet-buffer-tolerance > 0. None of these tests should be applied when the user has selected group kernels.

AFAIK they are not applied when the user has selected group kernels. They are applied when the new default to Verlet kernels is also applied. Berk is working on a patch to be a bit smarter - for NVE, infer a buffer from the temperature implied by gen_vel = yes or non-zero initial velocities.

The upload I just made provides some feedback to help a user understand that behaviour will change because the default has.

#5 Updated by Mark Abraham over 3 years ago

Szilárd Páll wrote:

IMO old files should behave as they did when created - as long as the respective feature is supported. While the results obtained with group and verlet schemes can be close, one can't just assume that they are freely interchangeable. Hence, I suspect most users would prefer to run the group scheme when providing an old tpr. To achieve this, we can just check the tpx version and with old tpr-s use the cutoff scheme which was default when the file was created.

Erik's original post pertained to .mdp files. At some point there has to be a change in the behaviour of an .mdp file that does not specify the cut-off scheme, and that time is now.

I agree that the behaviour of pre-4.6 .tpr file should be the group scheme. That is what happens if I run some .tpr files from the 4.5 regressiontests with mdrun from master, so I think your point is already resolved.

#6 Updated by Erik Lindahl about 3 years ago

  • Status changed from New to Closed

The warnings we added a few months ago solved this.

Also available in: Atom PDF