Project

General

Profile

Bug #1426

Group cutoff scheme yielding zero Coul-SR for SOL-SOL and tip4p, whereas verlet scheme does not

Added by Erik Marklund over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I had problems with unexpected LINCS errors appearing in my simulation of a protein dimer in water+NaCl. The error only occurred with group cutoffs, however. I eventually discovered that the SOL-SOL short-range potential energy was zero with the group cutoff, but not with the verlet cutoff. amber99sb-ildn and tip4p-Ew was used to model the system.

Here are the energies after a few em steps with verlet and group kernels, respectively. mdp files are nearly identical:

[marklund@ajbchap3 em2]$ diff em_group.mdp em.mdp
72c72
< cutoff-scheme            = group
---
> cutoff-scheme            = verlet
100c100
< vdw-modifier             = Potential-shift
---
> vdw-modifier             = Potential-shift-verlet

group
Energy                      Average   Err.Est.       RMSD  Tot-Drift
-------------------------------------------------------------------------------
Coul-SR:SOL-SOL                   0          0       -nan          0  (kJ/mol)

verlet
Energy                      Average   Err.Est.       RMSD  Tot-Drift
-------------------------------------------------------------------------------
Coul-SR:SOL-SOL             -948221      15000      32896    -104103  (kJ/mol)
em.tpr (3.15 MB) em.tpr Verlet scheme Erik Marklund, 01/22/2014 08:01 PM
em_group.tpr (3.14 MB) em_group.tpr Group scheme Erik Marklund, 01/22/2014 08:01 PM

History

#1 Updated by Mark Abraham over 5 years ago

  • Description updated (diff)

Need .tpr files, please.

#2 Updated by Erik Marklund over 5 years ago

Tpr files uploaded.

#3 Updated by Berk Hess over 5 years ago

Is this running on a machine with a GPU?
With the Verlet scheme on a GPU you don't get non-bonded energies split out per groups. Is that the issue here?

#4 Updated by Szilárd Páll over 5 years ago

Berk Hess wrote:

Is this running on a machine with a GPU?
With the Verlet scheme on a GPU you don't get non-bonded energies split out per groups. Is that the issue here?

The 0 energies were supposedly produced with the group scheme, hence I assume no GPU-s were used with the verlet scheme run.

#5 Updated by Erik Marklund over 5 years ago

No GPUs.

#6 Updated by Erik Lindahl over 5 years ago

  • Status changed from New to Resolved
  • Priority changed from High to Normal

I get realistic energies with the latest git version of the 4.6 branch. This was likely caused by combining shifted LJ with no modifier for PME, which might have led to the use of generic kernels, and then this was fixed by the previous patch that disabled solvent optimization for generic kernels ( https://gerrit.gromacs.org/#/c/3279/ ).

If you still think it's a problem, make sure that it's reproducible with the latest git version of 4.6.

#7 Updated by Erik Marklund over 5 years ago

That's good enough for me. I was merely comparing the performance of the group and verlet schemes for this system anyway.

#8 Updated by Rossen Apostolov over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF