Project

General

Profile

Task #1483

Fix warnings ignored by Jenkins

Added by Roland Schulz about 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
build system
Target version:
-
Difficulty:
uncategorized
Close

Description

We have a couple of warnings which are ignored by Jenkins. That makes the output harder to read and sometimes the parser does show it as warning.

1) cl : Command line warning D9002 : ignoring unknown option '-msse2'
This is caused by the fact that gmx_find_cflag_for_source in cmake/gmxFindFlagsForSource.cmake isn't checking for warnings when checking for the flags. We could use CheckCCompilerFlag.cmake which does check for warnings to fix this. Or is this done on purpose? Alternative we could also simply not add flags for x86-64 on Windows. Or we could disable the D9002 warning.

2) command line remark #10010: option '/GX' is deprecated and will be removed in a future release. See '/help deprecated'
Cause by cmake prior to 2.8.9. Workaround was removed by commit b2074da10d30de. We could either undo the commit, suppress the warning or use a newer cmake version for ICC on Windows.

3) direct access in [] to global weak symbo [] means the weak symbol cannot be overridden at runtime.
I don't really understand why we get that warning.


Related issues

Related to GROMACS - Bug #1461: CMake SIMD tests may add compiler flags that cause warnings Closed 03/15/2014
Duplicated by GROMACS - Bug #1535: osx C++ symbol visibility warnings Closed 06/27/2014

Associated revisions

Revision bc49850a (diff)
Added by Roland Schulz over 2 years ago

Add Intel command line warning

Fixes that build was printing a warning for scanner.cpp.

Related to #1483

Change-Id: I8a30fce82ab7ef0bfe735630b1ce4d9bb636b36d

History

#1 Updated by Teemu Murtola about 3 years ago

  • Related to Bug #1461: CMake SIMD tests may add compiler flags that cause warnings added

#2 Updated by Erik Lindahl almost 3 years ago

(1) has been fixed in #1461.

(2) Agree that updating our windows version is better than cluttering our CMake files with workarounds.

Can't help with (3) :-)

#3 Updated by Teemu Murtola almost 3 years ago

Which Jenkins configuration has 3)? I have some ideas of what could be the cause, and it's a bit hard to find them in Jenkins (which is the only environment where I could test the fixes).

#4 Updated by Roland Schulz almost 3 years ago

3 is Intel on Mac.

#5 Updated by Teemu Murtola almost 3 years ago

  • Duplicated by Bug #1535: osx C++ symbol visibility warnings added

#6 Updated by Teemu Murtola almost 3 years ago

  • Category set to build system
  • Target version set to 5.0

The first should now be fixed. The second should only require a change in Jenkins, not in the code. The third could be handled in the linked separate issue. So I propose this is closed after the second is done.

Set the target version based on where the code changes for the first issue were done.

#7 Updated by Roland Schulz over 2 years ago

2 has been fixed. Stefan updated cmake.

#8 Updated by Mark Abraham over 2 years ago

  • Target version changed from 5.0 to 5.x

#9 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1483.
Uploader: Roland Schulz ()
Change-Id: I8a30fce82ab7ef0bfe735630b1ce4d9bb636b36d
Gerrit URL: https://gerrit.gromacs.org/3904

#10 Updated by Roland Schulz over 2 years ago

  • Status changed from New to Closed

Stefan updated cmake and ICC to resolve 2 and 3.

#11 Updated by Mark Abraham 10 months ago

  • Target version deleted (5.x)

Also available in: Atom PDF