Project

General

Profile

Bug #15

trjconv skipping frame error

Added by Yang Ye about 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
High
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I have a xtc file of 51 frames (frame no. 2200-2300).

If I use
trjconv_d -f in.xtc -o out.xtc -b {x} -e 2300

if x is smaller than 5 (1...4), trjconv will stop at

Will write xtc: Compressed trajectory (portable xdr format)
Skipping frame 0 time 2200.00

error.pdb (871 KB) error.pdb bug15/36, structure for prot.xtc Juergen Haas, 01/12/2006 11:49 AM
prot.xtc (2.41 MB) prot.xtc bug15/36, traj to error.pdb Juergen Haas, 01/12/2006 11:50 AM

Related issues

Has duplicate GROMACS - Bug #36: two errors concerning trjconv -b -eClosed12/15/2005

History

#1 Updated by Yang Ye about 14 years ago

line #6 shall be

if x is smaller than 2205, trjconv will stop at

#2 Updated by David van der Spoel about 14 years ago

I cannot reproduce this problem, in the latest CVS code for 3.3. If you still
have the problem can you send me the xtc file (or provide a weblink)?

#3 Updated by Yang Ye about 14 years ago

Hi, David

Please close this bug. I could not find the original
file to reproduce it and all my versions of trjconv
could perform the task. I shall report if it occurs
again. Thanks.

Yang Ye

#4 Updated by Erik Lindahl about 14 years ago

David experienced it again on another trajectory - reopening.

#5 Updated by Erik Lindahl almost 14 years ago

David,

What's the status of this - I haven't heard anything, so I guess we should close it?

/Erik

#6 Updated by David van der Spoel almost 14 years ago

THere were recent complaints on the gmx-user list about g_order behaving
strangely. It looked like this bug, but I'm not sure about the version that was
used.

#7 Updated by Yang Ye almost 14 years ago

For this bug, it is very rare and can be encompassed by slicing .xtc into
individual frames. I suggest to close it with an open end.

I have met problems with g_rdf, g_rms in processing xtc (segmentation error)
while old versions could. The programs shall be compiled under the same
environment/settings. It could be a separated issue.

#8 Updated by Erik Lindahl almost 14 years ago

  • Bug 36 has been marked as a duplicate of this bug. ***

#9 Updated by Juergen Haas almost 14 years ago

Created an attachment (id=11)
bug15/36, structure for prot.xtc

#10 Updated by Juergen Haas almost 14 years ago

Created an attachment (id=12)
bug15/36, traj to error.pdb

#11 Updated by Juergen Haas almost 14 years ago

Hi David,

I have an example for an xtc that is short and buggy:

trjconv -f prot.xtc -o x.xtc -s error.pdb -b 4000 -e 4000
returns "WARNING no output, trajectory ended at 4000"

while
trjconv -f prot.xtc -o x.xtc -s error.pdb

works fine. (trjconv is of Version 3.3)

Jochen & Juergen

#12 Updated by David van der Spoel over 13 years ago

The real bug in reading xtc files is now fixed. The problem reported by Jochen
and Juergen is not a real bug, since they specify a zero interval and the time
in the file is not exact 4000 but 4000.00024. By spcifying either a short
interval around 4000 or using -dump this can be circumvented.

#13 Updated by Yang Ye over 13 years ago

Another problem with trjconv is that when converting an xtc. It will encounter
segmentation error when reading the first frame of the input. By specifying -b
(begin+1) can complete the task. It maybe relates to David's comment on "the time
in the file is not exact 4000 but 4000.00024".

#14 Updated by David van der Spoel over 13 years ago

Sorry Yang Ye, I don't understand your comment. Do you mean you have a correct
XTC file that will make trjconv crash with a SEGV? With a corrupt file that
could happen. If you have a correct one that does this, please upload the file
so that I can test it.

Also available in: Atom PDF