Project

General

Profile

Bug #1507

Support large systems with TNG

Added by Roland Schulz about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
core library
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Currently TNG is prohibitive slow for very large systems. I gave up waiting after ~10min to write a file for a system containing 2M atoms. The problem is that several functions search large tables for every atom in the system. E.g. tng_chain_residue_find (O(N^2), N: residues) or tng_residue_atom_w_id_add (O(NM) N: total number of atoms, M:atoms per residue). It seems, TNG needs to be profiled for a large system, and those searches need to be replaced with hash-table lookups.

Associated revisions

Revision 4aa9a806 (diff)
Added by Magnus Lundborg about 3 years ago

Improved check to decide if to add chain/residue.

Together with the latest TNG library updates this
fixes #1507

Change-Id: Iea7160cc1194fc398f9c4db0cc66f4bd43ce724a

History

#1 Updated by Rossen Apostolov about 3 years ago

There was a bug causing that and it was fixed in 1d33dec1ff75, release-5-0.

#2 Updated by Rossen Apostolov about 3 years ago

  • Status changed from New to Feedback wanted

#3 Updated by Roland Schulz about 3 years ago

I tested with recent master which already included this fix.

#4 Updated by Rossen Apostolov about 3 years ago

can you send me your inputs? because I've tried with the lignocellulose 3.3M and it seemed to work fine

#5 Updated by Rossen Apostolov about 3 years ago

Can you send/upload a test case to check?

#6 Updated by Rossen Apostolov about 3 years ago

  • Status changed from Feedback wanted to Accepted

#7 Updated by Gerrit Code Review Bot about 3 years ago

Gerrit received a related patchset '1' for Issue #1507.
Uploader: Magnus Lundborg ()
Change-Id: Iea7160cc1194fc398f9c4db0cc66f4bd43ce724a
Gerrit URL: https://gerrit.gromacs.org/3625

#8 Updated by Erik Lindahl about 3 years ago

  • Target version set to 5.x

#9 Updated by Erik Lindahl about 3 years ago

  • Status changed from Accepted to Fix uploaded

#10 Updated by Magnus Lundborg about 3 years ago

  • Status changed from Fix uploaded to Resolved

#11 Updated by Erik Lindahl about 3 years ago

  • Status changed from Resolved to Closed

#12 Updated by Teemu Murtola almost 3 years ago

  • Tracker changed from Feature to Bug
  • Category set to core library
  • Target version changed from 5.x to 5.0
  • Affected version set to 5.0

Also available in: Atom PDF