Project

General

Profile

Bug #153

Gromacs tools mistakenly change atom name OXT to O2 for PDB files

Added by Bob Johnson over 12 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
High
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

It seems like Gromacs tools such as editconf and grompp attempt to change atoms
named OXT to O2 when given a PDB file. For example, a PDB file that looks like this:

TITLE coordinates generated from amber coord file
MODEL 1
ATOM 1 OXT ALA 1 131.092 -26.777 133.195 1.00 0.00
TER
ENDMDL

will be converted into a file that looks like this:

TITLE coordinates generated from amber coord file
MODEL 1
ATOM 1 O2 ALA 1 131.092 -26.777 133.195 1.00 0.00
TER
ENDMDL

All that was done to generate this new file was type the command:
editconf -f OXT.pdb -o OXT-new.pdb

As you can see, the XT was changed to a 2. It seems that this transformation
ONLY occurs for OXT. Other atom names such as CXT or XXT were not changed after
using editconf. Additionally, substituting O2 for OXT occurs ONLY when the
editconf input file (-f file) is a PDB file.

I originally experienced this problem when using grompp. For example, I would type:
grompp -f input.mdp -c coordinates-containing-OXT-atom.pdb -p topology.top

I would then get an error saying that:
Warning: atom names in topology.top and coordinates.pdb don't match (OXT - O2)

So it looks like grompp also changes OXT to O2.

This problem has been reproduced on two machines. One running Fedora 6, the
other running Red Hat Enterprise Linux.

History

#1 Updated by David van der Spoel over 12 years ago

Removed this renaming in CVS code. There was a line in src/gmxlib/pdbio.c in routine gromacs_name which did this. The renaming of hydrogrens from e.g. 1HH3 to HH31 is maintained though.

Also available in: Atom PDF