Project

General

Profile

Bug #1579

virtual sites type N does not work with OpenMP

Added by Berk Hess over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

With OpenMP the use of virtual sites type N results in a segv or completely incorrect vsite coordinates.

vsiten.tgz (178 KB) David van der Spoel, 08/19/2014 10:25 AM

Associated revisions

Revision f86bed5e (diff)
Added by Berk Hess over 2 years ago

Fixed bugs in vsiteN with OpenMP

Fixes #1579.

Change-Id: I42d234f4ad6a94e8f7b6b8236ea119860dd9f7ab

Revision 0336ab2d (diff)
Added by David van der Spoel over 2 years ago

Fixes issue with vsiten and verlet buffers.

A loop counter for a loop over vsiten did not take into
account that multiple entries make up one vsiten
particle. Part of #1579.

Change-Id: Ic9a79e89ea9ef8f9f529c9d4a6c5cf05f65e9c7d

Revision f2007baa (diff)
Added by Berk Hess over 2 years ago

Fixes issue with vsiten and Verlet buffers

Commit 0336ab2d only fixed part of the vsiten issue in the Verlet
buffer calculation code. Parameters were read from incorrect memory
locations, which could lead to a segmentation fault or incorrect
masses for vsiten particles. It unlikely that this affected results.
Part of #1579.

Change-Id: I76cdb94e34194d2f6d49d98a49486ce1df76d91a

History

#1 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1579.
Uploader: Berk Hess ()
Change-Id: I42d234f4ad6a94e8f7b6b8236ea119860dd9f7ab
Gerrit URL: https://gerrit.gromacs.org/3912

#2 Updated by David van der Spoel over 2 years ago

The attached file reproduces the problem: the confout.gro shows that the vsiten particles have coordinates corresponding to 0 0 0 modulo a box length.

To reproduce:
grompp
mdrun

#3 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1579.
Uploader: David van der Spoel ()
Change-Id: Ic9a79e89ea9ef8f9f529c9d4a6c5cf05f65e9c7d
Gerrit URL: https://gerrit.gromacs.org/3964

#4 Updated by Berk Hess over 2 years ago

  • Status changed from In Progress to Closed

#5 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1579.
Uploader: Berk Hess ()
Change-Id: I76cdb94e34194d2f6d49d98a49486ce1df76d91a
Gerrit URL: https://gerrit.gromacs.org/4123

#6 Updated by Berk Hess over 2 years ago

  • Status changed from Closed to Fix uploaded
  • Target version changed from 4.6.7 to 4.6.8
  • Affected version changed from 4.6.6 to 4.6.7

https://gerrit.gromacs.org/4123 only fixed part of the grompp issue.
Due to incorrect parameter indexing, grompp could produce a segv, or nonsense parameters and thus vsite masses could be used for the buffer calculation. Since vsiten locations are usually heavy and/or used as interaction sites only, these have little or no effect on the buffer drift, so incorrect results are unlikely.

#7 Updated by Mark Abraham about 2 years ago

Berk Hess wrote:

https://gerrit.gromacs.org/4123 only fixed part of the grompp issue.

I don't understand - does 4123 complete the fix of 3912? If so, are we done here?

Due to incorrect parameter indexing, grompp could produce a segv, or nonsense parameters and thus vsite masses could be used for the buffer calculation. Since vsiten locations are usually heavy and/or used as interaction sites only, these have little or no effect on the buffer drift, so incorrect results are unlikely.

#8 Updated by Berk Hess about 2 years ago

  • Status changed from Fix uploaded to Resolved

My last update contained the wrong gerrit number. It should have said:
https://gerrit.gromacs.org/#/c/3912/ only fixed part of the grompp issue.
https://gerrit.gromacs.org/4123 fixed the rest.
So this issue has been fully resolved.

#9 Updated by Berk Hess about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF