Project

General

Profile

Bug #1586

xvg_format=exvgNULL by default

Added by Berk Hess about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
core library
Target version:
Affected version - extra info:
only dev versions
Affected version:
Difficulty:
uncategorized
Close

Description

pargs.cpp by default passes xvg_format=exvgNULL to output_env_init, which makes all legends etc dissappear from xvg files. I can't easily figure out what causes this.

Associated revisions

Revision 236deaf1 (diff)
Added by Teemu Murtola about 5 years ago

More consistent default handling for StringOption

For enumerated StringOptions, the enum indexes were not always
consistently handled. Added a few tests for the behavior, and fixed it.
Now the storeEnumIndex() option works consistently in that if the caller
specifies an initial value for the variable, and there is no other
default, the caller-provided value is preserved. Also, the stored enum
index is properly updated if a default value is provided through a value
in the output variable.

Fixes #1586

Change-Id: Ib9d24e977dbfde6b23ba90271574cdd43c70c1bd

History

#1 Updated by Teemu Murtola about 5 years ago

  • Status changed from New to In Progress
  • Assignee set to Teemu Murtola
  • Target version set to 5.1

I think I know where the problem is. I'll try to produce a fix and some additional tests in the next few days.

#2 Updated by Gerrit Code Review Bot about 5 years ago

Gerrit received a related patchset '1' for Issue #1586.
Uploader: Teemu Murtola ()
Change-Id: Ib9d24e977dbfde6b23ba90271574cdd43c70c1bd
Gerrit URL: https://gerrit.gromacs.org/3948

#3 Updated by Teemu Murtola about 5 years ago

  • Status changed from In Progress to Closed
  • Affected version - extra info set to only dev versions

Also available in: Atom PDF