Project

General

Profile

Bug #159

CVS mdrun writes broken molecules when using -dd

Added by Jochen Hub over 12 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

when using domain decomposition, the CVS mdrun writes broken molecules. E.g.,

mpirun C mdrun_cvs -v -dd 2 2 1 -s topol.tpr # topol.tpr is for 4 nodes

and

trjconv -s topol.tpr -f traj.xtc -dump 0.01 -o out.pdb

Gives an out.pdb with atoms inside the box. Using -pbc whole (actually, this is a different bug)

trjconv -s topol.tpr -f traj.xtc -pbc whole -o whole.pdb -dump 0.01

does not help.

Regards from Goettingen,
Jochen

(The Attached tpr is made for 4 nodes and runs only 10 steps.)

topol.tpr (2.95 MB) topol.tpr Test tpr (made with grompp 3.3.1) to run with CVS mdrun Jochen Hub, 08/01/2007 11:13 AM

History

#1 Updated by Jochen Hub over 12 years ago

Created an attachment (id=217)
Test tpr (make with grompp 3.3.1) to run with CVS mdrun

The tpr is for 4 nodes and runs only 10 steps.

#2 Updated by Erik Lindahl over 12 years ago

This is not a bug, but a consequence of the fact that there is no global graph when we apply domain decomposition. We'll update the documentation that says "gromacs doesn't write broken molecules" before we release 4.0, though.

#3 Updated by Jochen Hub over 12 years ago

(In reply to comment #2)

This is not a bug, but a consequence of the fact that there is no global graph
when we apply domain decomposition. We'll update the documentation that says
"gromacs doesn't write broken molecules" before we release 4.0, though.

Hi Erik, thanks for the quick reply. If from now on mdrun places all atoms in the box it would, however, be good if the "-pbc whole" and/or "-pbc com" options of trjconv would work. In my case, none of them changed the output of trjconv:

trjconv -f traj.xtc -o com.pdb -pbc com -s topol.tpr -dump 0.01

or

trjconv -f traj.xtc -o whole.pdb -pbc whole -s topol.tpr -dump 0.01

Here, in both com.pdb and whole.pdb all atoms are inside the box.

Regards,
Jochen

#4 Updated by Jochen Hub over 12 years ago

Ups, sorry, it seems that this has already been fixed. I just checked the -pdb whole option with the trjconv from the cvs version, and it works.

So, thanks again,
jochen

Also available in: Atom PDF