Project

General

Profile

Bug #1594

non-local stream priority dos not work with CUDA 5.5

Added by Szilárd Páll about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
mdrun
Target version:
Affected version - extra info:
5.x
Affected version:
Difficulty:
uncategorized
Close

Description

The bug is present only with CUDA 5.5 and is caused by an incorrect CUDA version check.

Associated revisions

Revision 89fae8d6 (diff)
Added by Szilárd Páll about 3 years ago

Fix malformed CUDA version macro check

The CUDA_VERSION macro check is incorrect in two places. The first is
harmless as it is related to legacy CUDA 3.2 version's reporting. The
second occurrence affects the check that enables stream priorities and
due to the incorrect check, with CUDA 5.5 priorities have not been used.

Fixes #1594

Change-Id: Icf781d41549c39b6b913c11bb11d4dc4e9f3be9c

History

#1 Updated by Szilárd Páll about 3 years ago

  • Description updated (diff)

#2 Updated by Gerrit Code Review Bot about 3 years ago

Gerrit received a related patchset '1' for Issue #1594.
Uploader: Szilárd Páll ()
Change-Id: Icf781d41549c39b6b913c11bb11d4dc4e9f3be9c
Gerrit URL: https://gerrit.gromacs.org/4028

#3 Updated by Szilárd Páll about 3 years ago

  • Status changed from New to Resolved

#4 Updated by Szilárd Páll about 3 years ago

  • Target version set to 4.6.8

#5 Updated by Mark Abraham almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF