Project

General

Profile

Bug #1639

GROMACS 5 - problem with LINCS with freeze groups

Added by Tomek Wlodarski almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

I have experienced some strange behaviour.
I am running test simulation to check freeze groups in gromacs-5.0.2 (using amber03w ff with TIP4P2005 water).
And I am getting LINCS Warnings for atoms which should be frozen...
Same situation is with Gromacs-4.6.7, but in Gromacs-4.6.5 simulation runs O.K.
I have attached grompp files.
Thanks.
Best,

tomek

nvt.mdp (1.74 KB) Tomek Wlodarski, 11/11/2014 03:58 PM

ubq.gro (1.64 MB) Tomek Wlodarski, 11/11/2014 03:59 PM

ubq.top (354 KB) Tomek Wlodarski, 11/11/2014 03:59 PM

Associated revisions

Revision 405cc128 (diff)
Added by Berk Hess over 2 years ago

Fixed twin-range + freeze + constraints

With twin-range cut-offs, atoms which are both frozen and constrained
would experience very large or NaN forces, leading to constraint
warnings and errors.
Fixes #1639.

Change-Id: I1871a87054fec1149c9ed75872451df79a8ac2d2

History

#1 Updated by Berk Hess over 2 years ago

  • Status changed from New to Accepted
  • Assignee set to Berk Hess

The issue is with the combination of three things: freeze-groups, constraints and twin-range interactions.
Solution 1: If you want to freeze the whole protein, you should not also constrain it, use constraints = none.
Solution 2: You are using twin-range interactions, which I don't know if that's on purpose. This can easily happen accidentally. You can set rcoulomb and rlist equal to rvdw=1.2. This will make the simulation slower, but more accurate.

I don't know if it is worth fixing this bug, since twin-range interaction are only supported with the group scheme, which is already deprecated.

#2 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1639.
Uploader: Berk Hess ()
Change-Id: I1871a87054fec1149c9ed75872451df79a8ac2d2
Gerrit URL: https://gerrit.gromacs.org/4236

#3 Updated by Berk Hess over 2 years ago

  • Category set to mdrun
  • Status changed from Accepted to Fix uploaded
  • Target version set to 5.0.3

The fix turned out to be trivial, so I pushed up a fix. Still solution 1 will circumvent the issue and give slightly better performance as well.

#4 Updated by Mark Abraham over 2 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF