Project

General

Profile

Bug #1651

System drift with md-vv

Added by Kristoffer Johansson about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
core library
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I am tryng to simulate a solid molecular crystal but the system builds up translational movement when I use the md-vv integrator with or without pressure coupling. With the leapfrog integrator this never happens.

Without symmetry constraints translation is indeed possible with close to zero friction for a crystallografic (periodic) cell but the center of mass removal should prevent this from happening.

Setting comm-grps to a central part of the system have no effect which may suggest that the center-of-mass removal i broken for md-vv.

verlet.mdp (1.77 KB) verlet.mdp Kristoffer Johansson, 12/03/2014 05:24 PM
az_verlet_gaff.tpr (137 KB) az_verlet_gaff.tpr Kristoffer Johansson, 12/04/2014 09:37 AM

Associated revisions

Revision 08b2d506 (diff)
Added by Michael Shirts about 2 years ago

Fix for lack of COM removal for md-vv

At some point, we seemed to have lost COM removal for md-vv! Currently, putting in into 4.6,
will need to be merged forward. Replaces https://gerrit.gromacs.org/#/c/4467/, which was
first checked into master, rather than 4.6.

Fixes #1651

Change-Id: I7776f4ad9b5b9458f294171f52b3581a04691250

History

#1 Updated by Mark Abraham about 3 years ago

Thanks - can you upload a .tpr that reproduces the problem, please?

For now I would recommend you use leapfrog - the original and ongoing testing of the VV integrator is not as good as we'd like it to be.

#2 Updated by Kristoffer Johansson about 3 years ago

Yes I am currently using the leapfrog integrator but it I would like to use vv for comparison with another software. The drift should be clear after ~10 ps.

Thanks.

#3 Updated by Michael Shirts about 3 years ago

Kristoffer Johansson wrote:

Yes I am currently using the leapfrog integrator but it I would like to use vv for comparison with another software. The drift should be clear after ~10 ps.

Thanks.

Can you say specifically what you observed? It makes it much easier to find if we have as much information as possible.

#4 Updated by Kristoffer Johansson about 3 years ago

Hi Michael,

I'm not sure if you are refering to my research or the problem so I'll try to answer both.

Regarding my research, I am looking for a low temperature solid-state phase transition from monoclinic to triclinic (box angles change). The energy landscape is quite smooth here so it is not a problem for a leapfrog simulation and other methods to find the triclinic structure.

However, as soon as I switch to md-vv I only observe heavy translational drift (as if the box moves in the bulk crystal) which kills the pressure coupling and a phase transition becomes impossible (due to fixed box angles). Center-of-mass removal should prevent this drift but fails to do so with md-vv.

Hope it clear things up. Otherwise, I will be happy to provide more info/files.
Kristoffer

#5 Updated by Kristoffer Johansson almost 3 years ago

Hi Mark, Michael and others,

Did you manage to reproduce the drift? If anyone can help I'm still very interested in a solution for this issue.

Kristoffer

#6 Updated by Gerrit Code Review Bot almost 3 years ago

Gerrit received a related patchset '1' for Issue #1651.
Uploader: Michael Shirts ()
Change-Id: I2659fe9422aef186c0cbc53ed8de3af0c1b53cd3
Gerrit URL: https://gerrit.gromacs.org/4467

#7 Updated by Michael Shirts almost 3 years ago

Kristoffer Johansson wrote:

Hi Mark, Michael and others,

Did you manage to reproduce the drift? If anyone can help I'm still very interested in a solution for this issue.

Kristoffer

OK, found a situation to reproduce the drift. Can you try the commit I put in? Note that this fix is currently in master.

Or perhaps wait until other people have commented to not waste too much time.

If this works, we will include it in bug-fix backports.

#8 Updated by Gerrit Code Review Bot over 2 years ago

Gerrit received a related patchset '1' for Issue #1651.
Uploader: Michael Shirts ()
Change-Id: I7776f4ad9b5b9458f294171f52b3581a04691250
Gerrit URL: https://gerrit.gromacs.org/4649

#9 Updated by Szilárd Páll over 2 years ago

  • Status changed from New to In Progress

#10 Updated by Michael Shirts about 2 years ago

  • Status changed from In Progress to Resolved

#11 Updated by Erik Lindahl over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF