Project

General

Profile

Bug #1656

Bug with 1D domain decomposition and fully triclinic boxes

Added by Berk Hess almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The fix for redmine issue #1631 for 1D domain decomposition along y broke the case for 1D DD (along x) with the second box vector x-component non-zero, or equivalently, the angle between vector 1 and 2 not 90 degrees. This was not detected right away, since the standard rhombic dodecahedron unit-cell in Gromacs has a 90 degree angle. This issue will cause obvious errors, unless the angle is very close, but not equal to, to 90 degrees.

To test for this we need to add a regression test case with all off-diagonal box elements non-zero.
To test for the issue of #1631 we can simply call on of the current dodecahedron test systems with -dd 1 ? 1.

Associated revisions

Revision 29b6eedc (diff)
Added by Berk Hess almost 3 years ago

Fix recent bug with trilinic 1D DD

A recent bug-fix (c8d919a3) for triclinic 1D domain decompostion
introduced a bug for boxes with box[YY][XX]!=0.
Fixes #1656.
Refs #1631.

Change-Id: I06b9376212390b73e90a3ce9704dee2bad9693fb

Revision 61f49916 (diff)
Added by Berk Hess almost 3 years ago

Add test cases to show bugs are fixed

  • octahedron adds a fully trilinic test case
  • dd121 adds a test case that will default to more
    ranks in a direction other than X (here, Y)

The reference data is generated with a "last known good" patch from
release-5-0 from before the fix for #1631 was introduced, not that it
really matters. The reference build is unaffected by any of the bugs,
because it runs single-core.

Refs #1631, #1656

Change-Id: I46c63a91aaae19a37bbe39e0c973cb9888019591

History

#1 Updated by Mark Abraham almost 3 years ago

Hmm redmine gerrit bots probably got broken in Rossen's upgrade.

#2 Updated by Mark Abraham almost 3 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF