Project

General

Profile

Bug #1683

mdrun-only build does not link correctly

Added by Mark Abraham almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Associated revisions

Revision 64f1d567 (diff)
Added by Mark Abraham almost 5 years ago

Fix mdrun-only build

The GMX_BUILD_ONLY_MDRUN build now does not include
the gmxpreprocess module. Some Verlet-scheme code moved
to mdlib because it it used in mdrun and grompp.

gmx membed uses a utility function otherwise used only in
gmxpreprocess, but the error message it gives is wrong for the gmx
membed context, so I duplicated the function definition for now. Noted
TODOs for future clean up.

Fixes #1683

Change-Id: Ibc1291e88151f8d5befac2b1840a41402272a05f

History

#1 Updated by Teemu Murtola almost 5 years ago

This is probably caused by mdrun wanting to link half the world, like all of pdb2gmx and gmx solvate. The code that these depend on could possibly be refactored so that they would not pull in all of selection code (if we want to keep the split at directory instead of file level), but even better would be to only link stuff that mdrun actually needs.

#2 Updated by Mark Abraham almost 5 years ago

Teemu Murtola wrote:

This is probably caused by mdrun wanting to link half the world, like all of pdb2gmx and gmx solvate. The code that these depend on could possibly be refactored so that they would not pull in all of selection code (if we want to keep the split at directory instead of file level), but even better would be to only link stuff that mdrun actually needs.

In terms of "modules," the mdrun-only build only added gmxpreprocess when it didn't need to, and it was fairly straightforward to modify to put the couple of shared functions back on the to-do list in mdlib :-).

#3 Updated by Gerrit Code Review Bot almost 5 years ago

Gerrit received a related patchset '1' for Issue #1683.
Uploader: Mark Abraham ()
Change-Id: Ibc1291e88151f8d5befac2b1840a41402272a05f
Gerrit URL: https://gerrit.gromacs.org/4455

#4 Updated by Mark Abraham over 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Mark Abraham

#5 Updated by Mark Abraham over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF