Project

General

Profile

Bug #1685

mdrun reports incorrect thread count use

Added by Szilárd Páll almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
core library
Target version:
Affected version - extra info:
5.1-dev-20150207-fc0c893
Affected version:
Difficulty:
uncategorized
Close

Description

mdrun has been reporting

Using 0 OpenMP thread per tMPI thread for PME

When it should in fact be reporting a >1 PP thread count. Some logic got obviously messed up.


Related issues

Is duplicate of GROMACS - Bug #1681: use of incorrect initial value of variableClosed02/06/2015

Associated revisions

Revision 6cb0f92a (diff)
Added by Berk Hess over 4 years ago

Fixed parallel distribution and thread count reporting

The domain decomposition no longer prints the atom count for all ranks
(which gets far too long at high parallelization), but rather av,
stddev, min and max.
Corrected the OpenMP thread count print, which often printed 0 thread
for (non-existent) PME ranks.
Fixes #1681, #1685.

Change-Id: Ia0e01c1c458e464ba2469d45c94d9e8c6b85d128

History

#1 Updated by Mark Abraham almost 5 years ago

  • Is duplicate of Bug #1681: use of incorrect initial value of variable added

#2 Updated by Gerrit Code Review Bot over 4 years ago

Gerrit received a related patchset '3' for Issue #1685.
Uploader: Berk Hess ()
Change-Id: Ia0e01c1c458e464ba2469d45c94d9e8c6b85d128
Gerrit URL: https://gerrit.gromacs.org/4472

#3 Updated by Szilárd Páll over 4 years ago

  • Category set to core library
  • Status changed from New to Resolved
  • Assignee set to Berk Hess
  • Target version set to 5.1

#4 Updated by Mark Abraham over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF