Project

General

Profile

Bug #1690

Lack of reproducibility with 5.04 even when run on one thread, same machine, etc.

Added by Michael Shirts over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
mdrun
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Command run with is:

$MDRUN -nt 1 -s runone.save2.tpr -reprod -deffnm runone -cpt 1000 -dhdl runone.dhdl.xvg

Crash sometimes occurs after 980 steps, but sometimes after 3000 steps, sometimes later, once after 740 steps, once went to 5000 steps w/o crashing

Haven't tested double precision yet; this was in single precision.

runone.save2.tpr (215 KB) Michael Shirts, 02/16/2015 07:25 PM

Associated revisions

Revision 52e33110 (diff)
Added by Erik Lindahl about 2 years ago

Fix reproducibility bug in fft5d

fft5d has been accessing FFTW directly instead of using the
Gromacs FFT interface, and while doing so the estimate flag was
not correctly set for reproducible runs. For now we have just
fixed it, but this FFTW-specific code should be removed from fft5d,
or we will likely see more fft bugs due to duplicated code paths.

Fixes #1690.

Change-Id: Ib03f7af710ed208d2824f105bd15712d32632cfa

History

#1 Updated by Erik Lindahl about 2 years ago

  • Status changed from New to Feedback wanted

Please provide all input files so we can debug by altering settings!

#2 Updated by Gerrit Code Review Bot about 2 years ago

Gerrit received a related patchset '1' for Issue #1690.
Uploader: Erik Lindahl ()
Change-Id: Ib03f7af710ed208d2824f105bd15712d32632cfa
Gerrit URL: https://gerrit.gromacs.org/4748

#3 Updated by Erik Lindahl about 2 years ago

  • Status changed from Feedback wanted to Fix uploaded

Fixed. fft5d has been doing monkey business by reimplementing its own FFTW interface, and in doing so it did not set flags correctly.

#4 Updated by Rossen Apostolov about 2 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF