Project

General

Profile

Bug #1740

invalid use of gmx_simd_check_and_reset_overflow

Added by Mark Abraham about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I try to compile GROMACS 5.0.5 on Fujitsu PRIMEHPC FX-10 with the command
from installation instruction page
http://www.gromacs.org/Documentation/Installation_Instructions_5.0#linear-algebra-libraries
I use the Fujitsu compiler with the custom build toolchain as suggestion
from the GROMACS webpage.
The command is:

>>  ~/software/cmake/bin/cmake ../
-DCMAKE_INSTALL_PREFIX=/home/k0055/k005503/software/gromacs  -DGMX_MPI=ON
-DCMAKE_TOOLCHAIN_FILE=../cmake/Platform/Toolchain-Fujitsu-Sparc64-mpi.cmake
-DCMAKE_PREFIX_PATH=/usr/local/fftw/3.3 -DGMX_BUILD_MDRUN_ONLY=ON
-DGMX_RELAXED_DOUBLE_PRECISION=ON

But unfortunately, I got this message after running make.

../../lib/libgromacs_mdrun_mpi_d.a(tpi.c.o): In function `do_tpi':
tpi.c:(.text+0x2130): undefined reference to
`gmx_simd_check_and_reset_overflow'
make[2]: *** [bin/mdrun_mpi_d] Error 1
make[1]: *** [src/programs/CMakeFiles/mdrun.dir/all] Error 2
make: *** [all] Error 2

Associated revisions

Revision 47b12697 (diff)
Added by Mark Abraham about 2 years ago

Fix misuse of gmx_simd_check_and_reset_overflow

Only x86 has useful definitions of this function. The check will
be entirely removed in master branch.

Fixes #1740

Change-Id: Ida1bc43201f44dffbd64d94bc485d4d6d882167b

Revision 8e46784a (diff)
Added by Mark Abraham almost 2 years ago

Remove gmx_simd_check_and_reset_overflow

We think this can only be implemented on x86, was only used for TPI,
and protected against an issue Berk can't reproduce. Thus best
removed.

Refs #1740

Change-Id: Ia8ca50b67683dab5a0e5e4a8b8485946edfd922a

History

#1 Updated by Gerrit Code Review Bot about 2 years ago

Gerrit received a related patchset '2' for Issue #1740.
Uploader: Mark Abraham ()
Change-Id: Ida1bc43201f44dffbd64d94bc485d4d6d882167b
Gerrit URL: https://gerrit.gromacs.org/4624

#2 Updated by Mark Abraham about 2 years ago

  • Status changed from New to Fix uploaded

#3 Updated by Mark Abraham about 2 years ago

  • Description updated (diff)

#4 Updated by Gerrit Code Review Bot almost 2 years ago

Gerrit received a related patchset '1' for Issue #1740.
Uploader: Mark Abraham ()
Change-Id: Ia8ca50b67683dab5a0e5e4a8b8485946edfd922a
Gerrit URL: https://gerrit.gromacs.org/4690

#5 Updated by Mark Abraham almost 2 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF