Project

General

Profile

Bug #1769

-deffnm ignored when using -multidir

Added by James Barnett over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
core library
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I have five directories where I am running five simultaneous free energy simulations. The node I'm running on has 2 GPU's and 20 cores (10 dual core processors). I go into each directory and run gmx grompp as normal. Then I go to the directory just above these and do the following:

mpirun -np 10 gmx mdrun -ntomp 2 -gpu_id 0000011111 -multidir C1 C2 C3 C4 C5 -deffnm min.0

The .tpr file I'm using in each directory (C1 through C5) is named "min.0.tpr", but mdrun gives me an error that "topol.tpr" cannot be found.

Specifying the .tpr file with the "-s" flag makes the error go away:

mpirun -np 10 gmx mdrun -ntomp 2 -gpu_id 0000011111 -multidir C1 C2 C3 C4 C5 -s min.0.tpr -deffnm min.0

But at this point all of the output files still go to the default (e.g., I would expect "min.0.log" to be output in each directory, but instead it is "md.log").

I can run a single simulation in each directory with -deffnm and it works as expected.

It seems that -deffnm is ignored when using -multidir. GROMACS 5.0.5 does not seem to have this issue.

Associated revisions

Revision 10a5f4c1 (diff)
Added by Teemu Murtola over 4 years ago

Fix -deffnm -multi[dir]

Make -deffnm work even when all other functionality in
FileNameOptionManager is disabled (which happens with -multi and
-multidir). Add a test for the broken case.

Fixes #1769.

Change-Id: I0f729eaa1ab6e9a4a25d1d121cbfe5b5b2673e4b

History

#1 Updated by Teemu Murtola over 4 years ago

  • Status changed from New to Accepted
  • Target version set to 5.1

This will be trivial to fix (the issue is easy to spot in FileNameOptionManager::completeDefaultFileName()), but I cannot do anything before Friday (at earliest).

#2 Updated by Gerrit Code Review Bot over 4 years ago

Gerrit received a related patchset '1' for Issue #1769.
Uploader: Teemu Murtola ()
Change-Id: I0f729eaa1ab6e9a4a25d1d121cbfe5b5b2673e4b
Gerrit URL: https://gerrit.gromacs.org/4875

#3 Updated by Teemu Murtola over 4 years ago

  • Category changed from mdrun to core library
  • Status changed from Accepted to Fix uploaded
  • Assignee set to Teemu Murtola

#4 Updated by James Barnett over 4 years ago

This fix works for me. Thanks.

#5 Updated by Teemu Murtola over 4 years ago

  • Status changed from Fix uploaded to Resolved
  • % Done changed from 0 to 100

#6 Updated by Mark Abraham over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF