Project

General

Profile

Bug #1778

gromacs 5 pdb2gmx doesn't pick up multiple torsions additive torsions in AMBER99sb-ILDN

Added by Chris Neale over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
preprocessing (pdb2gmx,grompp)
Target version:
-
Affected version - extra info:
5.0.5, 5.0.4
Affected version:
Difficulty:
uncategorized
Close

Description

For the AMBER99sb-ILDN force field, the gromacs aminoacids.rtp file contains multiple dihedrals (the extra ones added for ILDN) as torsion definitions like this in both gromacs versions 4.6.7 and 5.0.5:

ILE:
N CA CB CG2 torsion_ILE_N_CA_CB_CG2_mult1
N CA CB CG2 torsion_ILE_N_CA_CB_CG2_mult2

ASN:
C CA CB CG torsion_ASN_C_CA_CB_CG_mult1
C CA CB CG torsion_ASN_C_CA_CB_CG_mult2
C CA CB CG torsion_ASN_C_CA_CB_CG_mult3
C CA CB CG torsion_ASN_C_CA_CB_CG_mult4
C CA CB CG torsion_ASN_C_CA_CB_CG_mult5
C CA CB CG torsion_ASN_C_CA_CB_CG_mult6
CA CB CG ND2 torsion_ASN_CA_CB_CG_ND2_mult1
CA CB CG ND2 torsion_ASN_CA_CB_CG_ND2_mult2
CA CB CG ND2 torsion_ASN_CA_CB_CG_ND2_mult3
CA CB CG ND2 torsion_ASN_CA_CB_CG_ND2_mult4
CA CB CG ND2 torsion_ASN_CA_CB_CG_ND2_mult5
CA CB CG ND2 torsion_ASN_CA_CB_CG_ND2_mult6

However, while gromacs 4.6.7 pdb2gmx picks up all of these torsions correctly, gromacs 5.0.5 pdb2gmx appears to pick up only the first one. Therefore, ILE omits torsion_ILE_N_CA_CB_CG2_mult2 and ASN omits a total of 10 torsion terms.

My understanding from looking at the .top file output from pdb2gmx is that gromacs 5.0.5 pdb2gmx is not giving the user the correct force field.

For an AIA peptide:
$ diff gmx4.6.7.top gmx5.0.5.top|grep torsion
< 13 15 17 19 9 torsion_ILE_N_CA_CB_CG2_mult2

For an ANA peptide:
gpc-logindm01-ib0-$ diff gmx4.6.7.top gmx5.0.5.top|grep torsion
< 25 15 17 20 9 torsion_ASN_C_CA_CB_CG_mult2
< 25 15 17 20 9 torsion_ASN_C_CA_CB_CG_mult3
< 25 15 17 20 9 torsion_ASN_C_CA_CB_CG_mult4
< 25 15 17 20 9 torsion_ASN_C_CA_CB_CG_mult5
< 25 15 17 20 9 torsion_ASN_C_CA_CB_CG_mult6
< 15 17 20 22 9 torsion_ASN_CA_CB_CG_ND2_mult2
< 15 17 20 22 9 torsion_ASN_CA_CB_CG_ND2_mult3
< 15 17 20 22 9 torsion_ASN_CA_CB_CG_ND2_mult4
< 15 17 20 22 9 torsion_ASN_CA_CB_CG_ND2_mult5
< 15 17 20 22 9 torsion_ASN_CA_CB_CG_ND2_mult6

These differences persist in the processed topology that I get from grompp -pp

I have also checked gromacs 5.0.4 and it behaves the same way as gromacs 5.0.5.

I have attached a tarball of my testing for the AIA and ANA peptides. You will need to change two lines in run.sh where gromacs is placed in the PATH and GMXLIB is set (I currently have ". ~/.gmx4.6.7" or ". ~/.gmx5.0.5" to set these up).

Thank you,
Chris.

testFF.tgz (78.2 KB) testFF.tgz Package to reproduce pdb2gmx runs Chris Neale, 07/14/2015 08:40 PM

Related issues

Is duplicate of GROMACS - Bug #1755: gromacs topology file generated with amber99sb-ildn force fieldClosed2015-06-24
Is duplicate of GROMACS - Bug #1704: Multiple dihedrals v5.0.2Closed

History

#1 Updated by Teemu Murtola over 2 years ago

  • Is duplicate of Bug #1755: gromacs topology file generated with amber99sb-ildn force field added

#2 Updated by Teemu Murtola over 2 years ago

  • Is duplicate of Bug #1704: Multiple dihedrals v5.0.2 added

#3 Updated by Teemu Murtola over 2 years ago

  • Project changed from Support Platforms to GROMACS
  • Category set to preprocessing (pdb2gmx,grompp)
  • Status changed from New to Feedback wanted
  • Affected version changed from current to 5.0.5

This looks like an exact duplicate of several other already reported issues.

PS. The Support Platforms project is not for reporting Gromacs bugs, but for tracking issues that affect the infrastructure that supports Gromacs development (e.g., Redmine or continuous integration build machines).

#4 Updated by Chris Neale over 2 years ago

Agreed it is a duplicate. Sorry.

With respect to the "support platforms" vs "gromacs bugs", I am not aware that I selected support platforms. As I recall, I went here http://redmine.gromacs.org/projects/gromacs/issues/new and tried to add a new issue.

Thank you,
Chris.

#5 Updated by David van der Spoel over 2 years ago

  • Status changed from Feedback wanted to Resolved

I presume this was resolved by https://gerrit.gromacs.org/#/c/4772/.

#6 Updated by Erik Lindahl over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF