Project

General

Profile

Task #1783

investigate Apple OpenCL runtime usability

Added by Szilárd Páll over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
core library
Target version:
Difficulty:
uncategorized
Close

Description

A user report seems to indicate that some versions of Apple OpenCL runtime are buggy which also is supported by the fact that the OpenMM project warned about similar issues (although quite some time ago).

Update:
In the above linked thread a user reports that the OpenMM-relevant bugs were fixed recently, so that flags OS X versions >10.7.4 <10.10.3. as possibly problematic for GROMACS too.


Related issues

Related to GROMACS - Feature #1782: OpenCL runtime/compiler version should be reported in the log...Closed

Associated revisions

Revision c66e8fa3 (diff)
Added by Erik Lindahl over 4 years ago

Prevent AMD OpenCL on OS X prior to 10.10.4

OS X release 10.9.x has been confirmed to produce invalid OpenCL
kernels for AMD (but correct for NVIDIA), and we have tested that
it is fixed in 10.10.4. The fix might actually have appeared
already in 10.10.3, but it's not worth tracking down the exact
point since 10.10.5 is already out.
This change will issue a CMake warning when compiling GROMACS
on earlier OS X releases, and at runtime we check the version
again and mark AMD GPUs as incompatible.

Also fixed docs about the length of time JIT compilation takes
on AMD.

Refs #1783

Change-Id: I0202faea60c39daae6621d2bb9ba828aab5532a0

History

#1 Updated by Szilárd Páll over 4 years ago

  • Related to Feature #1782: OpenCL runtime/compiler version should be reported in the log... added

#2 Updated by Szilárd Páll over 4 years ago

  • Description updated (diff)

#3 Updated by Erik Lindahl over 4 years ago

  • Status changed from New to Fix uploaded

OpenCL on AMD cards is now disabled on OS X prior to 10.10.4 by https://gerrit.gromacs.org/#/c/4952/

#4 Updated by Gerrit Code Review Bot over 4 years ago

Gerrit received a related patchset '6' for Issue #1783.
Uploader: Szilárd Páll ()
Change-Id: I0202faea60c39daae6621d2bb9ba828aab5532a0
Gerrit URL: https://gerrit.gromacs.org/4952

#5 Updated by Mark Abraham over 4 years ago

  • Status changed from Fix uploaded to Closed

Also available in: Atom PDF