Project

General

Profile

Bug #183

system grompps fine in 3.3.1 but fails with a cryptic error in 3.3.2

Added by David Mobley almost 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I'm attaching a tarball of a peptide/TFE/water system that grompps fine in 3.3.1 for me, but fails with a cryptic error in 3.3.2. As far as I can tell my setup is fine (as evidenced by the fact it works fine in 3.3.1) so I suspect a bug, although it could also be that something about the topology format has changed without me being aware of it.

bug.tar.gz (276 KB) bug.tar.gz tarball to reproduce David Mobley, 01/04/2008 12:38 AM
splitter.c (19.3 KB) splitter.c spliiter.c source filee David van der Spoel, 01/04/2008 09:48 AM

History

#1 Updated by David Mobley almost 12 years ago

Created an attachment (id=270)
tarball to reproduce

tarball to reproduce

#2 Updated by David van der Spoel almost 12 years ago

I can confirm this bug, and simultaneously say that it has been fixed a while ago in 3.3.3 CVS. We should really release this version. You could try the attached src/kernel/splitter.c in 3.3.2 if you wish.

#3 Updated by David van der Spoel almost 12 years ago

Created an attachment (id=271)
spliiter.c source filee

Alternatively, you could use 3.3.1for making topologies. Anyway, if you patch the source please compare the resulting tpr files with the 3.3.1 tpr using gmxcheck.

Also available in: Atom PDF