Project

General

Profile

Bug #185

Wrong NH2-terminus charge groups in G53a6

Added by Jeroen van almost 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=272)
1AKI.pdb and G53a6 tops

There seems to be some inconsistent behaviour in the assignment of charge groups by pdb2gmx at the N terminus of proteins. See http://www.gromacs.org/pipermail/gmx-users/2008-January/031802.html. A quick investigation shows that it probably concerns every force field, except OPLS-AA/L, G43b1 and the Encads.

When pdb2gmx (gmx 3.3.1 and 3.3.2) is run on any protein (lysozyme 1AKI.pdb in this case) and an affected ff is chosen, it results in the following N-terminus topology:
[...]
; nr type resnr residue atom cgnr charge mass
1 NL 1 LYSH N 1 0.129 14.0067
2 H 1 LYSH H1 1 0.248 1.008
3 H 1 LYSH H2 1 0.248 1.008
4 H 1 LYSH H3 1 0.248 1.008
5 CH1 1 LYSH CA 2 0.127 13.019
6 CH2 1 LYSH CB 2 0 14.027
7 CH2 1 LYSH CG 3 0 14.027
8 CH2 1 LYSH CD 3 0 14.027
[...]
In this way, cg1 has a total charge of +0.873 and cg2 has a total charge of +0.127. I'd say it would be more consistent if CA gets assigned to cg1 instead of cg2, making the total charges +1 and 0, respectively.

For ffG53a6 (only!) it gets worse: when NH2 is selected as N-terminus pdb2gmx gives
[...]
; nr type resnr residue atom cgnr charge mass
1 NL 1 LYSH N 1 -0.66 14.0067
2 H 1 LYSH H1 1 0.44 1.008
3 H 1 LYSH H2 1 0.44 1.008
4 CH1 1 LYSH CA 2 -0.22 13.019
5 CH2 1 LYSH CB 2 0 14.027
6 CH2 1 LYSH CG 3 0 14.027
7 CH2 1 LYSH CD 3 0 14.027
[...]
, leading to a total charge of +0.22 for cg1 and -0.22 for cg2. In this case I'd say it would be even more logical to assign CA to cg1.

I have two side notes: I think it's quite strange that for ffG53a6 suddenly different charges are assigned to the NH2 terminus, as compared to ffG53a5 and previous GROMOS96 versions, with the CA charge suddenly changing from 0 to -0.22 (see above). The original 53a5/53a6 paper doesn't mention anything about a different parameterization of the N-terminus for G53a6 only. Are you guys sure this is not an error in ffG53a6-n.tdb?

The other thing is that IMHO it would be better to let pdb2gmx assign each subsequent neutral C* to its own charge group, instead of putting them in the same one (e.g. in this case CG and CD in cg3 and cg4). For the old gmx ff it works that way, but this is suddenly changed for G43a1 and higher (why?). Anyway, this is up to you to decide.

If you need more info, just let me know. :)

n-terminus.tar.gz (107 KB) n-terminus.tar.gz 1AKI.pdb and G53a6 tops Jeroen van, 01/17/2008 12:12 AM

History

#1 Updated by Jeroen van almost 12 years ago

OK, I found another comment, http://bugzilla.gromacs.org/show_bug.cgi?id=65#c5, and I can confirm that the first part of this 'bug' has already been fixed by David van der Spoel for the 3.3.2 release. The reason my 3.3.2 version was still doing it wrong is because it was still using the 3.3.1 library files, but that's fixed now. I guess that's what you get for being overzealous and tired at the same time. ;-)

So now only the second part of this report remains valid (and possibly the side notes), about the wrong cg assignment for a NH2 N-terminus with G53a6 only.

#2 Updated by David van der Spoel over 11 years ago

Thanks for a detailed bug report Jeroen. I've fixed this in CVS. It was a typo in the n.tdb (missing 0 at the line containing the CA in the NH2 group).

Also available in: Atom PDF