Project

General

Profile

Bug #194

shape of g_msd graph depends on time interval evaluated

Added by Gregor Bruns over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Category:
analysis tools
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Hi,

the shape of the g_msd .xvg graph seems to depend on the last frame evaluated (-e option).

I ran a 2 ns simulation of 486 ion pairs of 1,3-dimethylimidazolium chloride and evaluated the mean square displacement with g_msd. One would expect that the shape of the graph does not differ between 0 ps and 1000 ps if one evaluated the trajectory first between 0 and 2000 ps and then between 0 and 1200 ps (using the same input data file of course). Instead I got the contrary result, an increasing slope at the end of the graph, regardless of the last evaluation frame specified.
In the attachment msd-comparison.xvg I have collected four graphs created by g_msd with the same input trajectory, each beginning at 0 ps and ending at a different time, the problem is obvious.

This problem did occur in other simulations I ran, but in some other simulations the data analysis worked quite well (with minor discrepancies in slope).

My gromacs package was built 2008-17-03 on gentoo Linux.

Thanks for helping,
Gregor Bruns

msd-comparison.xvg (24.4 KB) msd-comparison.xvg Collection of msd graphs showing the problem. Gregor Bruns, 05/02/2008 01:58 PM
mdequi.mdp (1.18 KB) mdequi.mdp .mdp file used in the simulation Gregor Bruns, 05/02/2008 01:59 PM

History

#1 Updated by Gregor Bruns over 11 years ago

Created an attachment (id=277)
Collection of msd graphs showing the problem.

#2 Updated by Gregor Bruns over 11 years ago

Created an attachment (id=278)
.mdp file used in the simulation

#3 Updated by David van der Spoel over 11 years ago

Could you please specify the command line you used? In particular you may want to specify -trestart to be 0, and for comparing diffusion coefficients you also should check the-beginfit and -endfit options.

#4 Updated by David van der Spoel over 11 years ago

Did my previous comments resolve the problem?

#5 Updated by Berk Hess over 11 years ago

Hi,

I think you did not understand correctly what is in the graph.
The time t in the graph is not the actual simulation time,
but the time period over which the displacement is determined.
This is done for many different starting points (option -trestart),
not only starting at trajectory frame time 0.

Berk.

Also available in: Atom PDF