Project

General

Profile

Bug #2011

gmx clustsize -mol ignores index file

Added by David van der Spoel about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Low
Category:
analysis tools
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

When running gmx clustsize -mol the index file is ignored, meaning all water is taken into account as well when doing the analysis on a bunch of solute molecules.

Problem be circumvented by making a subset of the trajectory first.

History

#1 Updated by David van der Spoel about 3 years ago

  • Status changed from New to Accepted

#2 Updated by Mark Abraham almost 2 years ago

  • Target version deleted (2018)

#3 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Accepted to Rejected

The output of gmx clustsize clearly states "Using molecules rather than atoms. Not reading index file" in this case, so this is not a bug but rather functionality that was never implemented.

The only way for a generic tool to automatically handle the combination of indices and molecule-based properties would be for the tool to first check that the index file corresponds to only molecules, and then go through the entire topology to create a subset consisting of only the molecules you are interested in.

#4 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Rejected to Closed

Also available in: Atom PDF