Project

General

Profile

Bug #2027

pdb2gmx will read in multiple .rtp files but then when trying to add terminal patches it will not find anything from the additional .rtp file for the C-terminus

Added by Chris Neale about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

pdb2gmx will read in multiple .rtp files but then when trying to add terminal patches it will not find anything from the additional .rtp file for the C-terminus

test:
A. Use oplsaa.ff
B. Use a sequence ending in GLU
C. modify aminoacids.rtp to remove the [ GLU ] entry while new file aminoacids_more.rtp contains the [ GLU ] entry only

Note: new file aminoacids_more.rtp also contains the same header:
[ bondedtypes ]
; bonds angles dihedrals impropers all_dihedrals nrexcl HH14 RemoveDih
1 1 3 1 1 3 1 0

RESULT of pdb2gmx -ter:

with regular oplsaa.ff:
Select start terminus type for MET-1
0: NH3+
1: ZWITTERION_NH3+ (only use with zwitterions containing exactly one residue)
2: NH2
3: None
0
Start terminus MET-1: NH3+
No suitable end (C or 3') terminus found in database - assuming this residue
is already in a terminus-specific form and skipping terminus selection.

This happens even though with the modified folder gmx pdb2gmx outputs:

Reading residue database... (oplsaa_mod)
Opening force field file /nh/nest/u/cneale/exe/GROMACS/exec/gromacs-5.1.2/serial/share/gromacs/top/oplsaa_mod.ff/aminoacids.rtp
Residue 51
Sorting it all out...
Opening force field file /nh/nest/u/cneale/exe/GROMACS/exec/gromacs-5.1.2/serial/share/gromacs/top/oplsaa_mod.ff/aminoacids_more.rtp
Residue 52
Sorting it all out...

There is an obvious workaround, which is to have only one *.rtp file. However, if gromacs will only allow one then it should not say it is reading the other and, ideally, gromacs would either faithfully read and allow use of the other or throw an error if there is more than one *.rtp. I have no idea why I get OK N-terminal selection but faulty C-terminal selection. The reason to desire multiple rtp files is when adding new options to an existing force field then one does not pollute the original with the addition, thus making it cleaner to share modifications without one having to test that there were no undesired additions/deletions to the file.

This might be related to issue 2026

Associated revisions

Revision 61e5b736 (diff)
Added by Erik Lindahl almost 2 years ago

Don't require matching names between rtp and tdb files

This was only documented in the source. It's a remnant
from the days when all force fields were in the same
directory, and no longer necessary. With this change we
will properly match all termini to all amino acids.

Fixes #2026, #2027.

Change-Id: Ie7bf8e65892281cc2744146a5525be0c4afdcecf

History

#1 Updated by Chris Neale about 3 years ago

typo. Looks like I did not provide the regular oplsaa.ff output (which works as expected). Where my previous post says "with regular oplsaa.ff:" it should read "with modified oplsaa.ff:"

#2 Updated by Erik Lindahl almost 2 years ago

Technically this was not caused by ignoring additional files, but a requirement that the base names need to match between the file with the RTP and TDB entries.

#3 Updated by Erik Lindahl almost 2 years ago

  • Status changed from New to Fix uploaded

#4 Updated by Mark Abraham almost 2 years ago

  • Category set to preprocessing (pdb2gmx,grompp)
  • Assignee set to Erik Lindahl
  • Target version set to 2018

#5 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Fix uploaded to Resolved

#6 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF