Project

General

Profile

Bug #214

Configure fails in 64 bit

Added by David van der Spoel about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

I use the following compile script:

#!/bin/csh -f

setenv SW /sw
setenv DEST /Users/spoel/software-4.0
setenv CPPFLAGS -I${SW}/include
setenv LDFLAGS "-L${SW}/lib/x86_64 -L${SW}/lib -m64"
setenv CFLAGS "-m64 -Wall -Wno-unused -g"
setenv ASFLAGS ""

/Users/spoel/GROMACS/head/gmx/configure --prefix=${DEST} --host=x86_64-apple-dar
win --build=x86_64-apple-darwin

and it fails at the configure step with
checking whether your compiler can handle assembly files (.s)... no
configure: error: Upgrade your compiler (or disable assembly loops).
make: *
* No rule to make target `install'. Stop.

From config.log:

configure:30378: result: inline
configure:30403: checking whether your compiler can handle assembly files (*.s)
configure:30422: cc -c conftestasm.s
conftestasm.s:2:bad register name `%rsp'

History

#1 Updated by Erik Lindahl about 11 years ago

Hi David,

Confirmed - I don't remember exactly what I did to get this working before, but since there's a 10% performance boost we should fix it.

In principle I think 64 bit support should be turned on by default since it is so common, but perhaps we need a configure option to disable it and use 32 bit - both for testing and to support users with old ia32 laptops?

For a distribution disk image I'd like to support fat binaries, but I don't think we want the configure script to always compile two different versions of everything, since most of us won't need 32 bit support...

Cheers,

Erik

#2 Updated by Erik Lindahl about 11 years ago

Fixed in the 4.0 branch.

Also available in: Atom PDF