Project

General

Profile

Bug #215

Remove executable stacks in assembly kernels

Added by Jussi Lehtola almost 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

The assembly kernels do not have .note.GNU-stack declared, which results in executable stacks in the library code.

#if defined(linux) && defined(ELF)
.section .note.GNU-stack,"",%progbits
#endif

should be added to the end of each assembly file, which must be all preprocessed.

Or does this cause problems with Microsoft assembler?

History

#1 Updated by Erik Lindahl over 11 years ago

This is an interesting feature enhancement, but not really a bug.
The problem is that we have to keep the kernels compatible with half-a-dozen compilers, which in turn send them to 2-3 different assemblers.

These directives seem to have been introduced in binutils around 2005, which is still a little too modern for us to discontinue support for older x86 platforms, but we'll try to keep it in mind!

Also available in: Atom PDF