Project

General

Profile

Bug #2154

mdrun restart doesn't recognize pull-code files given default but unspecified names

Added by Chris Neale over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Dear users:

The following command works the first time, but gives the listed error message on subsequent calls:

gmx mdrun -notunepme -deffnm PULL -dlb yes -npme 0 -cpt 60 -maxh 499 -cpi PULL.cpt -ntmpi 4 -ntomp 6 -gpu_id 0123

Output file appending has been requested,
but some output files listed in the checkpoint file PULL.cpt
are not present or are named differently by the current progra:m
output files present: PULL.log PULL.xtc PULL.edr
output files not present or named differently: PULL_pullx.xvg PULL_pullf.xvg

###########################

I can fix by specifying -px and -pf like this:

gmx mdrun -notunepme -deffnm PULL -dlb yes -npme 0 -cpt 60 -maxh 499 -cpi PULL.cpt -ntmpi 4 -ntomp 6 -gpu_id 0123 -px PULL_pullx.xvg -pf PULL_pullf.xvg

######

I created a test system and attached it to reproduce this problem.

More info also available in replies to a post about this on gmx-users:
https://mailman-1.sys.kth.se/pipermail/gromacs.org_gmx-users/2017-April/112396.html
https://mailman-1.sys.kth.se/pipermail/gromacs.org_gmx-users/2017-April/112415.html (suggests its related to issue 942)


Related issues

Is duplicate of GROMACS - Bug #942: -deffnm with enforced rotation code writes files that break checkpoint resumeClosed

History

#1 Updated by Berk Hess over 3 years ago

  • Is duplicate of Bug #942: -deffnm with enforced rotation code writes files that break checkpoint resume added

#2 Updated by Berk Hess over 3 years ago

  • Status changed from New to Closed

This is a well known, old issue which will not be fixed.
The proper solution is to write all output to TNG instead of to separate files.

Also available in: Atom PDF