Project

General

Profile

Bug #2156

EwaldUnitTests fail on current master using -DGMX_DOUBLE=ON

Added by Aleksei Iupinov over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
core library
Target version:
Affected version - extra info:
Ubuntu/gcc 5.4, possibly other
Affected version:
Difficulty:
simple
Close

Description

As per user reports, in double precision builds some PME tests fail.
Specifically, it's 96 out of 144 force gathering tests on Ubuntu/gcc 5.4.
Typical output is like this:

...
Google Test trace:
/home/yupinov/gromacs/master/src/gromacs/ewald/tests/pmegathertest.cpp:404: Testing force gathering with CPU for PME grid size 13 15 11, order 5, 13 atoms, without reduction
/home/yupinov/gromacs/master/src/testutils/refdata.cpp:918: Failure
   In item: /Forces/[10]/Z
    Actual: 0.081070335928461704
 Reference: 0.081070341914709868
Difference: 5.98625e-09 (431354640 double-prec. ULPs, rel. 7.38e-08)
 Tolerance: abs. 3.33067e-15, 15 ULPs
...

Looks like the forces are always computed in single precision, but I'm not sure yet why don't all the tests fail.


Related issues

Related to GROMACS - Bug #2162: Several SIMD4 double precision reduce are actual single precisionClosed

History

#1 Updated by Aleksei Iupinov over 2 years ago

So it's PME order 3 which doesn't fail and PME orders of 4 and 5 that do fail (due to SIMD).
The issue goes away with GMX_SIMD=None.
Berk, is SIMD gather precision working as intended? Should I just use single-precision check always?

#2 Updated by Aleksei Iupinov over 2 years ago

  • Related to Bug #2162: Several SIMD4 double precision reduce are actual single precision added

#3 Updated by Aleksei Iupinov over 2 years ago

  • Category changed from testing to core library
  • Status changed from Accepted to In Progress

This is fixed by https://gerrit.gromacs.org/6598, just needs the merge into master.

#4 Updated by Aleksei Iupinov over 2 years ago

  • Status changed from In Progress to Closed

#5 Updated by Aleksei Iupinov over 2 years ago

  • Status changed from Closed to Resolved

#6 Updated by Berk Hess over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee changed from Aleksei Iupinov to Berk Hess

Also available in: Atom PDF