Project

General

Profile

Bug #2237

posres grompp run requires restraints.gro file

Added by Johannes Wagner about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
preprocessing (pdb2gmx,grompp)
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

if running grompp on the latest 2017 git master for a position restraint run, it throws an error that restraints.gro file is missing. same grompp on 2016 master runs fine.
If required, I can send a set of files on which to run grompp on. Don't know if it is general and easily reproducable, or somehow system dependent.

Associated revisions

Revision 871f2f46 (diff)
Added by Erik Lindahl almost 2 years ago

Document required position restraint files

Explain properly to users why the files are
suddenly required when it has worked fine without
them for a decade.

Fixes #2237.

Change-Id: I7990994d2da1f1af95b07bb0110b9bfdd89f3e25

History

#1 Updated by Berk Hess about 2 years ago

  • Status changed from New to Rejected

I changed this on purpose. I assume the error message told you you can supply the same file for -r as for -c.
We understand this breaks existing simulation protocols, but automatically using conf.gro for restraints can easily lead to incorrect restraint coordinates.

#2 Updated by Johannes Wagner about 2 years ago

Berk Hess wrote:

I changed this on purpose. I assume the error message told you you can supply the same file for -r as for -c.
We understand this breaks existing simulation protocols, but automatically using conf.gro for restraints can easily lead to incorrect restraint coordinates.

ok, good to know. The error message only says:

Program: gmx grompp, version 2017-dev
Source file: src/gromacs/utility/futil.cpp (line 514)

File input/output error:
restraint.gro

Only in gmx grompp -h one finds the clue that -r has restraint.gro as default.

#3 Updated by Mark Abraham almost 2 years ago

  • Status changed from Rejected to Accepted

I found this also. Berk's assumption is not correct. Output is e.g.

GROMACS:      gmx grompp, version 2018-rc1-dev-20180102-3bc43bb7f
Executable:   /home/marklocal/git/r2018/build-cmake-gcc-debug/install/bin/gmx
Data prefix:  /home/marklocal/git/r2018/build-cmake-gcc-debug/install
Working dir:  /home/marklocal/git/r2018/src/programs/mdrun/tests
Command line:
  gmx grompp -f membed -c OctaneSandwich -p OctaneSandwich

Replacing old mdp entry 'nstxtcout' by 'nstxout-compressed'
Setting the LD random seed to 1517196502
Generated 330891 of the 330891 non-bonded parameter combinations
Generating 1-4 interactions: fudge = 0.5
Generated 330891 of the 330891 1-4 parameter combinations
Excluding 3 bonded neighbours molecule type 'Protein'
turning all bonds into constraints...
Excluding 3 bonded neighbours molecule type 'OCT'
turning all bonds into constraints...
Excluding 1 bonded neighbours molecule type 'NA'
turning all bonds into constraints...
Excluding 1 bonded neighbours molecule type 'CL'
turning all bonds into constraints...
Excluding 3 bonded neighbours molecule type 'Protein'
Excluding 3 bonded neighbours molecule type 'OCT'
Excluding 2 bonded neighbours molecule type 'SOL'
turning all bonds into constraints...
Removing all charge groups because cutoff-scheme=Verlet

-------------------------------------------------------
Program:     gmx grompp, version 2018-rc1-dev-20180102-3bc43bb7f
Source file: src/gromacs/utility/futil.cpp (line 514)

File input/output error:
restraint.gro

For more information and tips for troubleshooting, please check the GROMACS
website at http://www.gromacs.org/Documentation/Errors
-------------------------------------------------------

Once we've read the topology and observed position restraints, then the -r (and perhaps -rb) files are no longer ffOPTRD, so we call gmx::File::exists() and give a useful fatal error accordingly.

#4 Updated by Gerrit Code Review Bot almost 2 years ago

Gerrit received a related patchset '1' for Issue #2237.
Uploader: Erik Lindahl ()
Change-Id: gromacs~release-2018~I7990994d2da1f1af95b07bb0110b9bfdd89f3e25
Gerrit URL: https://gerrit.gromacs.org/7418

#5 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Accepted to Resolved

#6 Updated by Erik Lindahl almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF