Project

General

Profile

Bug #226

water diffusion slower in 4.0 vs 3.3.3

Added by Martin Hoefling about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Erik Lindahl
Category:
mdrun
Target version:
Affected version - extra info:
Affected version:
Difficulty:
uncategorized
Close

Description

Created an attachment (id=289)
sample run input

In gromacs, compiled from 4.x source, the water diffusion in the attached run input is very low compared to the run performed with 3.3.3.

To reproduce:

-run tpr with both 3.x and 4.x for a couple 10000 steps
then what I did is using the 4.x version of g_msd
-g_msd -s topol.tpr -f traj.trr -b 0 -e 20

Values:
4.x
D[ SOL] 0.2991 (/- 0.3155) 1e-5 cm^2/s
3.x
D[ SOL] 3.3795 (
/- 0.0642) 1e-5 cm^2/s

The same happens if I create a 4.x run input file with same parameters.

topol.tpr (1.58 MB) topol.tpr sample run input Martin Hoefling, 10/13/2008 05:35 PM
run.mdp (8.76 KB) run.mdp run parameter file Martin Hoefling, 10/13/2008 05:42 PM
trajgmx3.xtc (3.09 MB) trajgmx3.xtc 80ps gromacs 3 trajectory Martin Hoefling, 10/13/2008 06:08 PM
trajgmx4.xtc (3.09 MB) trajgmx4.xtc 80ps gromacs 4 trajectory Martin Hoefling, 10/13/2008 06:08 PM
input.pdb (716 KB) input.pdb input structure Martin Hoefling, 10/13/2008 06:09 PM
index.ndx (245 KB) index.ndx index file (required for freezing gold atoms) Martin Hoefling, 10/13/2008 06:09 PM
md3.log (11.6 KB) md3.log gromacs 3.x mdrun logfile Martin Hoefling, 10/14/2008 05:45 PM
md4.log (10.6 KB) md4.log gromacs 4.x mdrun logfile Martin Hoefling, 10/14/2008 05:45 PM
topol.top (7.91 KB) topol.top Topology file Martin Hoefling, 10/15/2008 11:19 AM
posre.itp (676 Bytes) posre.itp position restraint topology include Martin Hoefling, 10/15/2008 11:20 AM
goldparams.tar.gz (50.8 KB) goldparams.tar.gz gold parameters included in topol.top Martin Hoefling, 10/15/2008 12:19 PM

History

#1 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=290)
run parameter file

#2 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=291)
80ps gromacs 3 trajectory

#3 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=292)
80ps gromacs 4 trajectory

#4 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=293)
input structure

#5 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=294)
index file (required for freezing gold atoms)

#6 Updated by Berk Hess about 11 years ago

The gmx4 trajectories looks very much like all your molecules
are position restrained.

Do you have position restraints on in the gmx4 run?
(you can look for posres energy terms in the log file).

Note that you can run you gmx3 tpr file with gmx4,
if you want to be sure that all the settings are the same.

Berk

#7 Updated by Martin Hoefling about 11 years ago

(In reply to comment #6)

The gmx4 trajectories looks very much like all your molecules
are position restrained.

Yepp, I agree - but nothing is defined in the run input.

Do you have position restraints on in the gmx4 run?
(you can look for posres energy terms in the log file).

I hope not, at least I didn't turn it on...
... I can't find the posres energy term you're mentioning. You're talking about md.log I assume? There's the following output: ======================================================
Step Time Lambda
1000 2.00000 0.00000 ======================================================

Energies (kJ/mol)
Bond Angle Proper Dih. Ryckaert-Bell. LJ-14
1.99381e+01 1.68287e+01 1.49371e+00 -9.68684e-01 2.38151e+01
Coulomb-14 LJ (SR) Coulomb (SR) Coul. recip. Potential
-9.14921e+01 1.98689e+04 -1.37444e+05 -1.12140e+04 -1.28820e+05
Kinetic En. Total Energy Conserved En. Temperature Pressure (bar)
2.11496e+04 -1.07670e+05 -6.53400e+04 2.98188e+02 -6.18582e+02
Cons. rmsd ()
5.86212e-07

I'll attach the logfiles of 3.x and 4.x with the first steps.

Note that you can run you gmx3 tpr file with gmx4,
if you want to be sure that all the settings are the same.

Yes, the above trajectory is already from running the 3.x tpr with 4.x mdrun.

Best
Martin

#8 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=295)
gromacs 3.x mdrun logfile

#9 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=296)
gromacs 4.x mdrun logfile

#10 Updated by David van der Spoel about 11 years ago

It looks like you are running a flexible water model with 2 fs time steps. While this can not explain everything, I would still urge you to use the identical tpr file from 3.3.3 for the run with 4.0-

#11 Updated by Berk Hess about 11 years ago

Could you attach the tpr files used for both simulations?

Berk

#12 Updated by Martin Hoefling about 11 years ago

(From update of attachment 289)
This run input has been used to produce the 3.x and 4.x trajectory.

#13 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=300)
Topology file

#14 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=301)
position restraint topology include

#15 Updated by Martin Hoefling about 11 years ago

(In reply to comment #11)

Could you attach the tpr files used for both simulations?

Just to avoid talking at cross-porposes. The first attachment of this bug, "sample run input" has been used to create both trajectories attached.

Maybe I was a bit unclear in my first statement mentioning, that I recreated a run input for 4.x. This is how I originally found out about the difference, which also means that creating a 4.x file with same structure, topology and run parameter file doesn't help.

#16 Updated by Berk Hess about 11 years ago

I have redone parts of your simulations and observe
the same problem.
This is very weird!

Could you provide all the required itp files?
I need at least:
ffoplsaag.itp
gold.itp

Berk

#17 Updated by Martin Hoefling about 11 years ago

Created an attachment (id=302)
gold parameters included in topol.top

#18 Updated by Martin Hoefling about 11 years ago

I can't guarantee, that these are the exactly same parameters as used for creating the topol.tpr but here, the problem is reproducible with those parameters.

#19 Updated by Berk Hess about 11 years ago

I found the problem.

With freeze groups with a Nose-Hoover thermostat
the velocities of frozen degrees of freedom are not set to zero.
In Gromacs 3 somehow these velocities got set to zero,
but I don't know how.

I committed fixes, both to set the initial velocities and
the velocities at each step to zero.

If you want a quick fix (except for the initial velocities)
the diff for src/mdlib/update.c is:
141c141,142
< } else
---

} else {
v[n][d] = 0.0;

142a144

}

Note that you have constraints between frozen particles.
This gives loads of constraint warnings and makes
the particles move slightly.

Berk

#20 Updated by Martin Hoefling about 11 years ago

(In reply to comment #19)

Thanks a lot for the fix. I'll cvs update and test it.

Note that you have constraints between frozen particles.
This gives loads of constraint warnings and makes
the particles move slightly.

Hmm between the frozen atoms? The idea is to have fixed charged atoms with a second charged atom bound via constraint. Are you referring to the LINCS warnings? The charges rotate more than 90DEG which I suppress by setting the environement variable:

GMX_MAXCONSTRWARN=-1

Best wishes
Martin

Also available in: Atom PDF